POJ 1007 DNA Sorting

链接:http://poj.org/problem?id=1007

DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 89319 Accepted: 35892

Description


One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.


Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.


Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA

TTTGGCCAAA


Source

East Central North America 1998

大意——对于一个序列的无序性可以使用相互之间无序的元素组的个数表示。问:对于给定的多个DNA字符串(长度相同,由A, C, G和T组成),从最有序到最无序进行排列,并且输出。

思路——定义一个结构体类型DNA,包含两个成员,一个str,表示DNA序列,一个count,表示逆序数。先计算出各DNA的逆序数,然后用sort函数对其按count进行从小到大排序,最后按排好序的数组进行输出即可。

复杂度分析——时间复杂度:O(m*n^2),空间复杂度:O(m*(m+n))

附上AC代码:


#include <iostream>
#include <cstdio>
#include <iomanip>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const double PI = acos(-1.0);
const int MAX = 100;
struct DNA
{
    string str;
    int count;
} dna[MAX];

bool cmp(DNA a, DNA b);

int main()
{
    ios::sync_with_stdio(false);
    int n, m;
    while (cin >> n >> m)
    {
        for (int i=0; i<m; i++)
        {
            cin >> dna[i].str;
            dna[i].count = 0;
        }
        for (int i=0; i<m; i++)
        {
            for (int j=0; j<n; j++)
                for (int k=j+1; k<n; k++)
                    if (dna[i].str[j] > dna[i].str[k])
                        dna[i].count++;
        }
        sort(dna, dna+m, cmp);
        for (int i=0; i<m; i++)
            cout << dna[i].str << endl;
    }
    return 0;
}

bool cmp(DNA a, DNA b)
{
    return a.count < b.count;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值