POJ 1182 食物链

http://poj.org/problem?id=1182

食物链

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 55565 Accepted: 16296

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

Source


题意不解释,中文的。但是这题坑的地方绝对不敢想象:居然不可以用多样例输入。真的是醉了,就这个问题,无尽的WA,555555。


看解题大概的思路吧:






仔细斟酌,相信你会有所收获的。这是我们老师的讲义。


附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <deque>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
typedef long long ll;
const double pi = acos(-1.0);
const double e = exp(1.0);
const double eps = 1e-8;
const int maxn = 50005;
int p[maxn];
short r[maxn];
int n, k;

int find(int x);
void merge(int x, int y, short h);

int main(){
	ios::sync_with_stdio(false);
	// freopen("input.txt", "r", stdin);
	// freopen("output.txt", "w", stdout);
	scanf("%d%d", &n, &k);
	int ans = 0;
	for (int i=1; i<=n; i++)
		p[i] = i;
	short d;
	int x, y;
	while (k--){
		scanf("%hd%d%d", &d, &x, &y);
		if (x>n || y>n){
			ans++;
			continue;
		}
		if (1 == d){
			if (find(x) == find(y)){
				if (r[x] != r[y])
					ans++;
			}
			else
				merge(x, y, 0);
		}
		else{
			if (find(x) == find(y)){
				if (r[x] != ((r[y]+1)%3))
					ans++;
			}
			else
				merge(x, y, 1);
		}
	}
	printf("%d\n", ans);
	return 0;
}

int find(int x){
	if (p[x] == x)
		return x;
	int t = p[x];
	p[x] = find(p[x]);
	r[x] = (r[t]+r[x])%3;
	return p[x];
}

void merge(int x, int y, short h){
	int a=find(x), b=find(y);
	p[a] = b;
	r[a] = (r[y]-r[x]+3+h)%3;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值