POJ 3981 字符串替换

一、题目信息

字符串替换
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7501 Accepted: 3560

Description

编写一个C程序实现将字符串中的所有"you"替换成"we"

Input

输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束

Output

对于输入的每一行,输出替换后的字符串

Sample Input

you are what you do

Sample Output

we are what we do

二、参考代码

#include <string> 
#include <iostream>
using namespace std;
int main()
{
    string str;
    while(getline(cin,str))
    {
        string::size_type pos = 0;
        while ( (pos = str.find("you", pos)) != string::npos ) {
            str.replace( pos++, 3, "we" );
        }
        cout << str << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值