HDU 1002 大数加法(C语言)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 340946    Accepted Submission(s): 66112


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
思路详见代码:
#include<stdio.h>
#include<string.h>
int main()
{
	char a[2005];	//a,b接收加数 
	char b[2005];
	int ans[2005];	//存储相加结果 
	int t,flag;
	int index=1;
	int len1,len2;
	scanf("%d",&t);
	while(t--)
	{
		memset(ans,0,sizeof(ans));	//每次赋零 
		scanf("%s%s",a,b);
		len1=strlen(a);
		len2=strlen(b);
		int i=len1-1;	//i,j分别指向a,b待处理的位置。 
		int j=len2-1;
		int p=0;	//指向ans中待处理的位置 
		
		while(i>=0 && j>=0)		//做加法运算 ,直到一个字符串被算完。 
		{
			if(ans[p]+(a[i]-'0')+(b[j]-'0')>9)	//大于9,进位。 
			{
				ans[p]=(ans[p]+(a[i]-'0')+(b[j]-'0'))%10;
				ans[p+1]++;
			}
			else
			{
				ans[p]=ans[p]+(a[i]-'0')+(b[j]-'0');
			}
			i--;j--;p++;
		}
	
		if(i>=0)	//当a有剩余时就单独和a做运算。 
		{
			while(i>=0)
			{
				if(ans[p]+(a[i]-'0')>9)
				{
					ans[p]=(ans[p]+(a[i]-'0'))%10;
					ans[p+1]++;
				}
				else
				{
					ans[p]=ans[p]+(a[i]-'0');
				}
				i--;p++;
			}
		}
		else if(j>=0)
		{
			while(j>=0)
			{
				if(ans[p]+(b[j]-'0')>9)
				{
					ans[p]=(ans[p]+(b[j]-'0'))%10;
					ans[p+1]++;
				}
				else
				{
					ans[p]=ans[p]+(b[j]-'0');
				}
				j--;p++;
			}
		} 
		flag=0;
		printf("Case %d:\n",index);	index++;
		printf("%s + %s = ",a,b);
		for(int i=p;i>=0;i--)
		{
			if(ans[i]==0 && flag==0)//加标记位,防止过多的前缀0 
				continue;
			else
			{
				flag=1;
				printf("%d",ans[i]);
			}
		}
		printf("\n");
		if(t)
			printf("\n");
	}
	return 0;
}



  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值