Max sum HUD1003(dp)

Max Sum


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

题目简单,基础的dp,难点在于记录子序列的开始和结束位置;


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>

using namespace std;
struct DP{
    int s, e, val;//s:起点;e:终点;val:子串的和;
}dp[100005];
int a[100005];
int main(){
    int T;
    scanf("%d", &T);
    int cnt=0;
    while(T--){
        cnt++;
        int n;
        scanf("%d",&n);
        for(int i=1; i<=n; i++){
            scanf("%d",&a[i]);
            dp[i].val=a[i];    //初始化和,每个元素都是一个子串;
            dp[i].e=i;        //初始化终点为i;
        }
        int s, e, maxx, k;
        maxx=dp[1].val;
        k=1;
        dp[1].s=1;
        dp[1].e=1;
        for(int i=2; i<=n; i++)//dp[i]=max(dp[i-1]+a[i], a[i]);
        {
            if(dp[i-1].val+a[i] >=a[i]){
                dp[i].val=dp[i-1].val+a[i];
                dp[i].s=dp[i-1].s;
            }
            else{
                dp[i].val=a[i];
                dp[i].s=i;
            }
            if(maxx<dp[i].val){
                maxx=dp[i].val;
                k=i;
            }
        }
        printf("Case %d:\n",cnt);
        printf("%d %d %d\n",maxx,dp[k].s,dp[k].e);
        if(T!=0) printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值