【小顶堆】关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:
F
T
F
T

作者: 陈越
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB

分析:
1、小顶堆的父结点小于等于左右子结点。
2、判断很麻烦,仔细。
3、建堆不需要用二叉树(代码复杂且低效),直接数组。
代码:

#include<bits/stdc++.h>
using namespace std;
int N,M,a[1001];
void Build(int n,int a[])
{
    for (int i=1;i<n;i++)
    {
        int j=i;
        while(j!=0&&a[(j-1)/2]>a[j])
        {
            int c=a[j];
            a[j]=a[(j-1)/2];
            a[(j-1)/2]=c;
            j=(j-1)/2;
        }
    }
}
int findit(int w)
{
    for (int i=0;i<N;i++)
    {
        if (w==a[i]) return i+1;
    }
}
int main()
{
    cin>>N>>M;
    for (int i=0;i<N;i++)
    {
        cin>>a[i];
    }
    Build(N,a);
    /*for (int i=0;i<N;i++)
    {
        cout<<a[i]<<' ';
    }*/
    for (int i=0;i<M;i++)
    {
        int x,y;
        cin>>x;
        string s1;
        cin>>s1;
        if (s1=="and")
        {
            cin>>y;
            if (findit(x)/2==findit(y)/2)
                cout<<"T"<<endl;
            else
                cout<<"F"<<endl;
            string s2,s3;
            cin>>s2>>s3;
        }
        else
        {
            string s2;
            cin>>s2;
            if (s2=="a")
            {
                string s3,s4;
                cin>>s3>>s4>>y;
                if (findit(x)/2==findit(y))
                {
                    cout<<"T"<<endl;
                }
                else
                    cout<<"F"<<endl;
            }
            else
            {
                string s3;
                cin>>s3;
                if (s3=="root")
                {
                    if (findit(x)==1)
                    {
                        cout<<"T"<<endl;
                    }
                    else
                        cout<<"F"<<endl;
                }
                else
                {
                    string s4;
                    cin>>s4>>y;
                    if (findit(x)==findit(y)/2)
                    {
                        cout<<"T"<<endl;
                    }
                    else
                        cout<<"F"<<endl;
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值