题目描述:
For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(Gmid−term ×40%+Gfinal ×60%) if Gmid−term >Gfinal , or Gfinal will be taken as the final grade G. Here Gmid−term and Gfinal are the student’s scores of the mid-term and the final exams, respectively.
The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.
输入格式:
Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.
Then three blocks follow. The first block contains P online programming scores Gp’s; the second one contains M mid-term scores Gmid−term’s; and the last one contains N final exam scores Gfinal’s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).
输出格式:
For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:
StudentID Gp Gmid−term Gfinal G
If some score does not exist, output “−1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID’s. It is guaranteed that the StudentID’s are all distinct, and there is at least one qullified student.
输入样例:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81
输出样例:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84
题意:
给出一组中国大学MOOC中数据结构课程学生的成绩,包括线上编程成绩、期中考试成绩和期末考试成绩。如果期中考试大于期末考试成绩,最终成绩为期中考试成绩 * 0.4+期末考试成绩 * 0.6,如果不满足,则最终成绩等于期末考试成绩。要求线上编程成绩>=200,最终成绩>=60的学生可以获得合格证书。将可以获得合格证书的学生按最终成绩由高到低输出。如果最终成绩相同,按学生ID从小到大输出。
思路:
合理利用STL容器。
参考代码:
#include <iostream>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int p, m, n; //总人数,期中考试成绩列表,期末考试成绩列表
struct student{
string sId;
int gp, gmid, gfinal, gtotal;
student(){
gp = gmid = gfinal = gtotal = -1;
}
};
map<string, student> stu; //成绩整合表
map<string, int> stuID; //统计有多少在线编程可以通过的人数
bool cmp(student a, student b){
if(a.gtotal != b.gtotal) return a.gtotal > b.gtotal;
else return a.sId < b.sId;
}
int main(){
scanf("%d%d%d", &p, &m, &n);
int idx = 1; //编号
string id; //临时变量
int score;
for(int i = 0; i < p; i++){
cin >> id >> score;
if(score >= 200){
stu[id].gp = score;
stu[id].sId = id;
if(stuID[id] == 0) stuID[id] = idx++;
}
}
for(int i = 0; i < m; i++){
cin >> id >> score;
if(stuID[id] != 0) stu[id].gmid = score;
}
student res[idx]; //在线成绩合格人数>=总体合格人数
int ridx = 0;
for(int i = 0; i < n; i++){
cin >> id >> score;
if(stuID[id] != 0){
stu[id].gfinal = stu[id].gtotal = score;
if(stu[id].gmid > stu[id].gfinal){
stu[id].gtotal = round(stu[id].gmid * 0.4 + stu[id].gfinal * 0.6);
}
if(stu[id].gtotal >= 60) res[ridx++] = stu[id];
}
}
sort(res, res + ridx, cmp);
for(int i = 0; i < ridx; i++){
cout << res[i].sId << " " << res[i].gp << " " << res[i].gmid << " " << res[i].gfinal << " " << res[i].gtotal << endl;
}
return 0;
}