POJ1679The Unique MST

The Unique MST

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions:35416 Accepted: 12924

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

POJ Monthly--2004.06.27 srbga@POJ

问题链接:POJ1679The Unique MST

问题分析:先计算最小生成树,然后通过最小生成树计算次小生成树,可参考博文次小生成树

程序说明:程序使用prim算法计算最小生成树,

AC的C++程序:

#include<iostream>
#include<cstring>

using namespace std;

const int N=103; 
const int INF=0x3f3f3f3f;
int g[N][N],path[N][N];//g为图的邻接矩阵,path记录结点i到结点j路径上的最大值;
bool used[N][N];//记录边是否被加入最小生成数
int pre[N],dist[N];//pre记录一个结点的前一个结点 dist记录距离

//求最小生成数 
int prim(int n)//结点数为n
{
	bool vis[N];//判断结点i是否被添加 
	memset(vis,false,sizeof(vis));
	memset(path,0,sizeof(path));
	memset(used,false,sizeof(used));
	memset(dist,INF,sizeof(dist));
	pre[1]=0;
	dist[1]=0;
	vis[1]=true;
	for(int i=2;i<=n;i++){
		pre[i]=1;
		dist[i]=g[1][i];
	}
	int mst=0;
	for(int i=1;i<n;i++){
		int temp=INF,k=0;
		for(int j=1;j<=n;j++)
		  if(!vis[j]&&dist[j]<temp)
		    temp=dist[k=j];
	    if(k==0)
	      return -1;//不存在最小生成树
	    mst+=dist[k];
		used[pre[k]][k]=used[k][pre[k]]=true;//这条边被添加进了最小生成树
		vis[k]=true;
		//更新
		for(int j=1;j<=n;j++){
			if(vis[j]&&j!=k)
			  path[j][k]=path[k][j]=max(dist[k],path[j][pre[k]]);
			else if(!vis[j]&&dist[j]>g[k][j]){
				dist[j]=g[k][j];
				pre[j]=k;
			}
		}
	}
	return mst;
} 

int second_mst(int n,int mst)
{
	int ans=INF;
	for(int i=1;i<=n;i++)
	  for(int j=i+1;j<=n;j++)
	    if(!used[i][j]&&g[i][j]!=INF)
	      ans=min(ans,mst-path[i][j]+g[i][j]);
	if(ans==INF)//不存在次小生成树 
	  return -1;
	return ans;
}

int main()
{
	int t,n,m,x,y,w;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		  for(int j=1;j<=n;j++)
		    g[i][j]=(i==j)?0:INF;
		while(m--){
			scanf("%d%d%d",&x,&y,&w);
			g[x][y]=g[y][x]=w;
		} 
		int mst=prim(n);
		if(mst!=-1){//如果存在最小生成树的话 
			int ans=second_mst(n,mst);
			if(ans!=-1&&ans==mst)
			  printf("Not Unique!\n");
			else
			  printf("%d\n",mst);
		}
	}
	return 0;
}
 
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值