HDU1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 428374    Accepted Submission(s): 83225


 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 99887766554433221

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L

问题连接:HDU1002A + B Problem II

问题分析:大数加法,C语言用字符数组,C++用字符串

AC的C语言代码:

#include<stdio.h>
#include<string.h>

#define max(a,b) a>b?a:b
#define N 1000

char sa[N+1],sb[N+1];
int a[N+1],b[N+1];

int main()
{
	int i,j,k,t;
	scanf("%d",&t);
	for(k=1;k<=t;k++){
		scanf("%s%s",sa,sb);
		//字符串转数值数组
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
	    int alen=strlen(sa);
		int blen=strlen(sb);
		for(i=alen-1,j=0;i>=0;i--,j++)
		  a[j]=sa[i]-'0';
		for(i=blen-1,j=0;i>=0;i--,j++)
		  b[j]=sb[i]-'0';
		//相位相加
		int len=max(alen,blen);
		int carry=0;
		for(i=0;i<len;i++){
			a[i]+=b[i]+carry;
			carry=a[i]/10;
			a[i]%=10;
		} 
		if(carry!=0)
		  a[len++]=carry;
		//输出
		printf("Case %d:\n",k);
		printf("%s + %s = ",sa,sb);
		for(i=len-1;i>=0;i--)
		  printf("%d",a[i]);
		printf("\n");
		if(k!=t)
		  printf("\n"); 
	}
	return 0;
}

AC的C++代码:

#include<iostream>
#include<cmath>
#include<string>

using namespace std;

int main()
{
	int t,i,j;
	string a,b,A,B;
	cin>>t;
	for(i=1;i<=t;i++){
		cin>>A>>B;
		a=A;
		b=B;
		string add=(a.length()>b.length())?a:b;
		int len=abs((int)(a.length()-b.length()));
		if(a.length()>b.length())
		  b.insert(0,len,'0');
		else
		  a.insert(0,len,'0');
		int carry=0;
		for(j=a.length()-1;j>=0;j--){
			add[j]=(carry+(a[j]-'0')+(b[j]-'0'))+'0';
			if(j!=0){
				if(add[j]>'9'){
					add[j]-=10;
					carry=1;
				}
				else
				    carry=0;
			}
		}
		if(add[0]>'9'){
			add[0]-=10;
			add.insert(0,1,'1');
		}
		cout<<"Case "<<i<<":"<<endl;
		cout<<A<<" + "<<B<<" = "<<add<<endl;
		if(i!=t)
		  cout<<endl;
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
电子图书资源服务系统是一款基于 Java Swing 的 C-S 应用,旨在提供电子图书资源一站式服务,可从系统提供的图书资源中直接检索资源并进行下载。.zip优质项目,资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松copy复刻,拿到资料包后可轻松复现出一样的项目。 本人系统开发经验充足,有任何使用问题欢迎随时与我联系,我会及时为你解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(若有),项目具体内容可查看下方的资源详情。 【附带帮助】: 若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步。 【本人专注计算机领域】: 有任何使用问题欢迎随时与我联系,我会及时解答,第一时间为你提供帮助,CSDN博客端可私信,为你解惑,欢迎交流。 【适合场景】: 相关项目设计中,皆可应用在项目开发、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面中 可借鉴此优质项目实现复刻,也可以基于此项目进行扩展来开发出更多功能 【无积分此资源可联系获取】 # 注意 1. 本资源仅用于开源学习和技术交流。不可商用等,一切后果由使用者承担。 2. 部分字体以及插图等来自网络,若是侵权请联系删除。积分/付费仅作为资源整理辛苦费用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值