HDU3635 Dragon Balls【带权并查集 统计】

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8372    Accepted Submission(s): 3088


 

Problem Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

Author

possessor WC

Source

2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU

问题链接:HDU3635 Dragon Balls

问题描述:有N颗龙珠和N座城市(均从1开始编号),开始时第i颗龙珠放置在第i个城市,有两种类型的操作,T A B表示将龙珠A及与A在一起的龙珠移动到龙珠B的位置,Q A表示查询龙珠A所在的城市,该城市共有多少龙珠,已经龙珠A转移的次数

解题思路:带权并查集,三个数组 pre存储i的父节点,sum存储以i为父节点的节点个数,cnt存储i被转移的次数。对find函数和join函数的改写看代码

AC的C++代码:

#include<iostream>

using namespace std;

const int N=10010;
int pre[N],sum[N],cnt[N];//pre存储i的父节点,sum存储以i为父节点的节点个数,cnt存储i被转移的次数
int n;

void init(int n)
{
	for(int i=0;i<=n;i++){
		pre[i]=i;//初始化为自己是自己的父节点 
		sum[i]=1;//只有自身一个 
		cnt[i]=0;//还未被转移过 
	}
} 

int find(int x)
{
	if(x!=pre[x]){
		int r=pre[x];
		pre[x]=find(r);
		cnt[x]+=cnt[r];
	}
	return pre[x];	
}

void join(int x,int y)
{
	int fx=find(x);//龙珠x的祖先节点是龙珠fx 
	int fy=find(y);//龙珠y的祖先节点是龙珠fy
	if(fx!=fy){//如果fx和fy不是同一个,就要将以fx为祖先节点的龙珠转移到fy 
		pre[fx]=fy;
		sum[fy]+=sum[fx];//与fy在一起的龙珠个数要加上fx那一堆
		cnt[fx]++;//龙珠fx转移了一次 
	} 
}

int main()
{
	int T,q;
	scanf("%d",&T);
	for(int t=1;t<=T;t++){
		scanf("%d%d",&n,&q);
		init(n);
		printf("Case %d:\n",t);
		while(q--){
			char c;
			int a,b;
			scanf(" %c",&c);
			if(c=='T'){
				scanf("%d%d",&a,&b);
				join(a,b);
			}
			else if(c=='Q'){
				scanf("%d",&a);
				int r=find(a);
				printf("%d %d %d\n",r,sum[r],cnt[a]);
			}
		}
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值