POJ1733 Parity game【离散化+带权并查集 区间统计】

Parity game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12597 Accepted: 4874

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source

CEOI 1999

问题链接:POJ1733 Parity game

问题描述:给定一个01串(长度不超过1000000000),有若干条件,X Y even表示区间[X,Y]内有偶数个1,X Y odd表示区间[X,Y]内有奇数个1,输出前几个条件是满足的。

解题思路:带权并查集:区间统计。由于数据量较大,需要离散化处理。pre存储i的父节点,num存储i到父节点之间1的数量,h存储查询出现的点 ,具体修改看程序

AC的C++程序:

#include<iostream>
#include<algorithm>

using namespace std;

const int N=5010;

struct Query{
	int u,v,d;//d=1表示[u,v]中1的数量为奇数,d=2表示偶数 
}q[N];

int pre[N],num[N],h[2*N];//pre存储i的父节点,num存储i到父节点之间1的数量,h存储查询出现的点 

void init(int n)
{
	for(int i=0;i<=n;i++){
		pre[i]=i;//初始化自己为父节点 
		num[i]=0;
	}
}

int find(int x)
{
	if(x!=pre[x]){
		int r=pre[x];
		pre[x]=find(r);
		num[x]^=num[r];
	}
	return pre[x];
}

bool join(int x,int y,int d)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){//此时不能计算出[x,y]之间的1的个数,合并两个端点 
		pre[fy]=fx;
		num[fy]=(2+num[x]-num[y]+d)%2;
	}
	else{
		if((num[x]+d)%2!=num[y])
		 return false;
	}
	return true;
}

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m)){
		int ans=0,cnt=0,u,v;
		char s[10];
		for(int i=0;i<m;i++){
			scanf("%d%d%s",&q[i].u,&q[i].v,s);
			if(s[0]=='o')
			  q[i].d=1;
			else if(s[0]=='e')
			  q[i].d=0;
			h[cnt++]=q[i].u-1;
			h[cnt++]=q[i].v;
		}
		sort(h,h+cnt);
		cnt=unique(h,h+cnt)-h;//去重,查询的端点可能有重复
		init(cnt);
		for(int i=0;i<m;i++){
			//查询两个端点在h数组中的下标位置 
			u=lower_bound(h,h+cnt,q[i].u-1)-h;
			v=lower_bound(h,h+cnt,q[i].v)-h;
			if(join(u,v,q[i].d))
			  ans++;
			else
			  break;
		} 
		printf("%d\n",ans);
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值