POJ1463 Strategic game【树形DP】

Strategic game

Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 9697 Accepted: 4569

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 

  •  
  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

Southeastern Europe 2000

问题链接:POJ1463 Strategic game

题目描述:如果一个点上放士兵,那么与这个点相连的路都会被看守住,现在问如果要把所有路都看守住,至少需要放多少士兵。

解题思路:树形DP,dp[i][0]表示结点i不放士兵,dp[i][1]表示结点i放士兵。

dp[node][1]+=min(dp[v][0],dp[v][1]);   //结点node放士兵,与其相连的结点就可以不用放可不放 
dp[node][0]+=dp[v][1];    //结点node不放士兵,那么与其相连的结点就必须放 。找出父节点,然后对父节点进行DP

AC的C++程序:

#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>

using namespace std;

const int N=1510;

vector<int>g[N];
int dp[N][2];//dp[i][0]表示结点i不放士兵,dp[i][1]表示结点i放士兵
bool vis[N];//找出父节点 

void tree_dp(int node)
{
	for(int i=0;i<g[node].size();i++)
	{
		int v=g[node][i];
		tree_dp(v);
		dp[node][1]+=min(dp[v][0],dp[v][1]);//结点node放士兵,与其相连的结点就可以不用放可不放 
		dp[node][0]+=dp[v][1];//结点node不放士兵,那么与其相连的结点就必须放 
	}
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		  g[i].clear();
		memset(vis,true,sizeof(vis));
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++)
		  dp[i][1]=1;
		int root=0;
		for(int i=0;i<n;i++)
		{
			int k,a,b;
			scanf("%d:(%d)",&a,&k);
			while(k--)
			{
				scanf("%d",&b);
				g[a].push_back(b); 
				vis[b]=false;//结点b不是根结点 
			}
		}
		for(int root=0;root<n;root++)
		  if(vis[root])
		  {
		  	tree_dp(root);
		  	printf("%d\n",min(dp[root][0],dp[root][1])); 
		  	break;
		  }
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值