POJ1056 IMMEDIATE DECODABILITY【字典树】

IMMEDIATE DECODABILITY

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14888 Accepted: 7055

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

Examples: Assume an alphabet that has symbols {A, B, C, D} 

The following code is immediately decodable: 
A:01 B:10 C:0010 D:0000 

but this one is not: 
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

Source

Pacific Northwest 1998

问题链接:POJ1056 IMMEDIATE DECODABILITY

问题描述:给定一个01串集合,如果所有的01串均不是其他01串的前缀输出“is immediately decodable“否则输出”is not immediately decodable“(还要先输出集合号,每个集合用9分割)

解题思路:字典树,具体看程序

AC的C++程序:

#include<iostream>
#include<cstring>

using namespace std;

const int N=100;
int trie[N][2],tot;
bool isw[N];//是否是单词的结束 

bool insert(char *s)
{
	int rt=0;
	bool flag=true;//假定s是已经插入的01串的前缀,或者已经插入的01串是s的前缀
	bool firt=true;//是否是第一次遇到 trie[rt][x]等于0的情况 
	for(int i=0;s[i];i++)//进行插入操作 
	{
		int x=s[i]-'0'; 
		if(!trie[rt][x])//如果rt不存在儿子结点x 
		{
		//如果第一次遇到trie[rt][x]等于0且rt不是单词的结束 那么字符串s就不会是已经插入的01串的前缀,
		//已经插入的01串也不会是s的前缀   
			if(firt&&!isw[rt]) 
			  flag=false;
			firt=false; 
			trie[rt][x]=++tot;
		} 
		rt=trie[rt][x];//更新下次进行插入操作的父节点 
	}
	isw[rt]=true;//标记rt是单词s的结束
	return flag;//返回s是否是已经插入单词的前缀 
} 

int main()
{
	char s[15];
	bool flag=false;
	int cnt=0;
	while(~scanf("%s",s))
	{
		if(s[0]=='9')
		{
			printf("Set %d is %simmediately decodable\n",++cnt,flag?"not ":"");
			//为下次做准备
			flag=false;
			memset(trie,0,sizeof(trie));
			memset(isw,false,sizeof(isw)); 
			tot=0;
		}
		else
		{
			if(insert(s)==true)
			  flag=true;
		} 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值