POJ1364 King【差分约束】

King

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14805 Accepted: 5232

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

Central Europe 1997

问题链接:POJ1364 King

问题描述:已知一个序列a[1], a[2], ......, a[n],给出它的若干子序列以及对该子序列的约束条件,例如a[si], a[si+1], a[si+2], ......, a[si+ni],且a[si]+a[si+1] * +a[si+2]+......+a[si+ni] < or > ki。求是否存在满足以上m个要求的数列。是则输出“lamentable kingdom”,否则输出“successful conspiracy”。

解题思路:差分约束,求最短路或者最长路都行,只要出现了对应的环就表明不存在,否则表示存在。以下程序使用最短路

AC的C++程序:

#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>

using namespace std;

const int N=105;
const int INF=0x3f3f3f3f;

struct Edge{
	int v,w;
	Edge(int v,int w):v(v),w(w){}
};

vector<Edge>g[N];

int dist[N];
bool vis[N];
int cnt[N];

bool spfa(int s,int n)
{
	memset(vis,false,sizeof(vis));
	memset(cnt,0,sizeof(cnt));
	fill(dist,dist+N,INF);
	queue<int>q;
	q.push(s);
	cnt[s]=1;
	vis[s]=true;
	dist[s]=0;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		for(int i=0;i<g[u].size();i++)
		{
			int v=g[u][i].v;
			int w=g[u][i].w;
			if(dist[v]>dist[u]+w)
			{
				dist[v]=dist[u]+w;
				if(!vis[v])
				{
					q.push(v);
					vis[v]=true;
					if(cnt[v]++>n)
					  return false;//存在负环 
				}
			}
		}
	}
	return true;
}

int main()
{
	int n,m,a,b,c;
	char str[5];
	while(~scanf("%d",&n)&&n)
	{
		for(int i=0;i<N;i++)
		  g[i].clear();
		scanf("%d",&m);
		while(m--)
		{
			scanf("%d%d%s%d",&a,&b,str,&c);
			if(str[0]=='g')    //s[a]-s[a+b+1]<=-(c+1)
			  g[a+b+1].push_back(Edge(a,-(c+1)));
			else if(str[0]=='l') //s[a+b+1]-s[a]<=c-1
			  g[a].push_back(Edge(a+b+1,c-1));
		}
		//添加超级源点
		for(int i=1;i<=n+1;i++)
		  g[0].push_back(Edge(i,0));
		bool flag=spfa(0,n+2);
		printf("%s\n",flag?"lamentable kingdom":"successful conspiracy");
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值