L2-012 关于堆的判断

                                                     L2-012 关于堆的判断

                           https://pintia.cn/problem-sets/994805046380707840/problems/994805064676261888

 

 

题目

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

样例输入

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

样例输出

F
T
F
T

分析

二叉堆

C++程序

#include<iostream>
#include<string>
#include<map>

using namespace std;

const int N=1005;

int a[N];
map<int,int>pos;

//向堆中插入元素 
void up(int start)
{
	int c=start,tmp=a[c];
	while(c>0&&a[(c-1)/2]>tmp)
	{
		a[c]=a[(c-1)/2];
		c=(c-1)/2;
	}
	a[c]=tmp;
}

int main()
{
	int n,m,x,y;
	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		up(i);
	}
	for(int i=0;i<n;i++)
	  pos[a[i]]=i;//元素a[i]的位置在i 
	while(m--)
	{
		string s,s1,s2,s3,tmp;
		cin>>x>>s;
		if(s=="is")
		{
			cin>>s1>>s2;
			s3=s1+s2;
			if(s3=="theroot")
			{
				printf("%c\n",(pos[x]==0)?'T':'F');
			}
			else if(s3=="theparent")
			{
				cin>>tmp>>y;
				printf("%c\n",((pos[y]-1)/2==pos[x])?'T':'F');
			}
			else if(s3=="achild")
			{
				cin>>tmp>>y;
				printf("%c\n",((pos[x]-1)/2==pos[y])?'T':'F');
			}
		}
		else 
		{
			cin>>y;
			getline(cin,tmp);
			//是否为兄弟
			printf("%c\n",((pos[x]-1)/2==(pos[y]-1)/2)?'T':'F');
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值