POJ3250 Bad Hair Day【单调栈】

Bad Hair Day

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24310 Accepted: 8264

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow ican see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

Source

USACO 2006 November Silver

题意

一群高度不同的牛从左到右排开,每头牛只能看见它右边的比它矮的牛的发型,若遇到一头高度大于或等于它的牛,则无法继续看到这头牛后面的其他牛。求所有的牛能够看见发型总数。

思路

维护一个单调递减栈。当前牛的高度如果小于栈顶元素就入栈,否则就一直出栈,直到栈空或者栈顶元素大于当前牛的高度,结果加上此时栈内的元素个数,表示能看到这条牛的发型的牛的数量。

C++代码

#include<iostream>

using namespace std;

const int N=80010;
int st[N],top=0;

int main()
{
	int n,h;
	long long ans;
	while(~scanf("%d",&n))
	{
		top=0,ans=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&h);
			while(top>0&&st[top]<=h) top--;
			ans+=top;//答案加上比当前牛的高度 h高的牛的个数(即能看见当前牛的发型的牛的数量) 
			st[++top]=h;
		}
		printf("%lld\n",ans);
	} 
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值