POJ2823 Sliding Window【单调队列】

Sliding Window

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 76785 Accepted: 21745
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki

题意

给你一个长度为N的数组,一个长为K滑动的窗体从最左移至最右端,你只能见到窗口的K个数,每次窗体向右移动一位,你的任务是找出窗口在各位置时的最小值和最大值

思路

单调队列模板题

C++代码

#include<iostream>
#define NOTMONO (ASC&&a[q[rear]]>a[i]||!ASC&&a[q[rear]]<a[i])//判断是否满足单调性 

using namespace std;

const int N=1000100;

int a[N],q[N],front,rear,n,k;

//ASC=true表示维护单增队列求最小值,false表示维护单减队列求最大值 
void solve(bool ASC)
{
	front=1,rear=0;
	for(int i=1;i<=n;i++)
	{
		while(front<=rear&&(NOTMONO)) rear--;//如果当前元素破坏了单调性就出队列 
		q[++rear]=i;//将当前元素的编号入队列 
		while(q[front]<=i-k) front++;//保证队头元素在窗口内 
		if(i>=k) printf("%d%c",a[q[front]],i==n?'\n':' ');
	}
} 

int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		for(int i=1;i<=n;i++)
		  scanf("%d",&a[i]);
		solve(true);//求最小值 
		solve(false);//求最大值 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值