POJ2886 Who Gets the Most Candies?【线段树 点修改】

Who Gets the Most Candies?

http://poj.org/problem?id=2886

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 16835 Accepted: 5298
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

Source

POJ Monthly--2006.07.30, Sempr

题意

 n个孩子按顺时针排列,每个人手上都有一张牌,牌上有一个数字,从第k个孩子开始出队,出队的孩子卡上数字是val,则从他开始顺时针第val人是下一个出队的,负数则逆时针数那个第val个人,第P个出队的会得到的糖果数是p的因子个数,输出得到最多糖果的人和他的糖果数,如果有多个,则输出最先出队的人。

思路

先打表求出1-500000的因子个数,然后使用线段树,点修改,区间信息为这个区间还剩下多少人。

C++代码

#include<iostream>

using namespace std;

#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1

const int N=500050;

char name[N][15];
int val[N];
int f[N];//f[i]=j,表示数i有j个因子 
int sum[N<<2];

//打表求f[n] 
void maketable(int n)
{
	for(int i=1;i<n;i++) 
	  f[i]=1;
	for(int i=2;i<n;i++)
	  for(int j=i;j<n;j+=i)
	    f[j]++;
}

int getorder(int n)
{
	int k=1;
	for(int i=2;i<=n;i++)
	  if(f[k]<f[i])
	    k=i;
	return k;
}

void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void build(int l,int r,int rt)
{
	if(l==r)
	{
		sum[rt]=1;
		return;
	}
	int m=(l+r)>>1;
	build(ls);
	build(rs);
	pushup(rt);
}

int update(int num,int l,int r,int rt)
{
	if(l==r)
	{
		sum[rt]=0;
		return l;
	}
	int m=(l+r)>>1;
	int res;
	if(num<=sum[rt<<1])
	  res=update(num,ls);
	else
	  res=update(num-sum[rt<<1],rs);
	pushup(rt);
	return res;
}

int main()
{
	int n,k;
	maketable(N);
	while(~scanf("%d%d",&n,&k))
	{
		for(int i=1;i<=n;i++)
		  scanf("%s%d",name[i],&val[i]);
		  
		build(1,n,1);
		int order=getorder(n);//出队次序为 order 的人获得的糖果最多 
		
		int pos=0,num=k,total=n,ln=0,rn=0;
		
		for(int i=1;i<=order;i++)
		{
			pos=update(num,1,n,1);
			total--;
			ln=num-1;//删除元素左边的人的数量 
			rn=total-num+1;//删除元素右边的人的数量
			if(i==order) break;//找到第order个出队的人,跳出
			//获取下一个出队的人是现在队列中的第num个人,即求num 
			int v=val[pos];//v表示跳跃值 
			if(v>0)
			{
				v%=total;
				if(!v) v=total;
				if(v<=rn)
				  num=ln+v;
				else
				  num=v-rn;
			} 
			else
			{
				v=-v;
				v%=total;
				if(!v) v=total;
				if(v<=ln)
				  num=ln-v+1;
				else
				  num=total-v+ln+1;
			}
		}
		printf("%s %d\n",name[pos],f[order]); 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值