CCPC2018-湖南全国邀请赛 HDU6281 Sorting【排序】

Sorting

http://acm.hdu.edu.cn/showproblem.php?pid=6281

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2402    Accepted Submission(s): 615


 

Problem Description

Bobo has n tuples (a1,b1,c1),(a2,b2,c2),…,(an,bn,cn).
He would like to find the lexicographically smallest permutation p1,p2,…,pn of 1,2,…,n such that for i∈{2,3,…,n} it holds that

 

Input

The input consists of several test cases and is terminated by end-of-file.

The first line of each test case contains an integer n.
The i-th of the following n lines contains 3 integers ai, bi and ci.

 

Output

For each test case, print n integers p1,p2,…,pn seperated by spaces.
DO NOT print trailing spaces.

## Constraint

* 1≤n≤10^3
* 1≤ai,bi,ci≤2×10^9
* The sum of n does not exceed 10^4.

Sample Input

2
1 1 1
1 1 2
2
1 1 2
1 1 1
3
1 3 1
2 2 1
3 1 1

Sample Output

2 1
1 2
1 2 3

Source

CCPC2018-湖南全国邀请赛-重现赛(感谢湘潭大学)

题意

给定n个三元组,求[1...n]的一个字典序最小的排列,排列满足题目的要求

思路

排序,要注意精度问题,不要将long long类型的数转double后比较。

C++代码

#include<iostream>
#include<cmath>
#include<algorithm>

using namespace std;

typedef long long ll;

const int N=1050;
const double ESP=1e-6;

struct Tuple{
	int id;
	ll x,y;
	bool operator<(const Tuple &h)const
	{
		ll t1=y*h.x,t2=x*h.y;
		return t1==t2?id<h.id:t1>t2;
	}
}t[N];

int main()
{
	int n;
	ll a,b,c;
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%lld%lld%lld",&a,&b,&c);
			t[i].id=i,t[i].x=a+b,t[i].y=c;
		}
		sort(t+1,t+n+1);
		for(int i=1;i<=n;i++)
		  printf("%d%c",t[i].id,i==n?'\n':' ');
	}
	return 0;  
} 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值