SDNUOJ 1359.GPA

Time Limit: 1000 MS    Memory Limit: 32768 KB
Total Submission(s): 411    Accepted Submission(s): 185

Description

Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.

Input

The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

Output

Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.

Sample Input

A B C D F
B F F C C A
D C E F

Sample Output

2.00
1.83
Unknown letter grade in input

Source

Unknown

key:见注释

#include<bits/stdc++.h>
using namespace std;
#define db double
 
char s[100008];
db sum=0,num=0;
int i=0,flag=0;
 
int main()
{
	while(gets(s))
	{
		sum=0;
		num=0;
		flag=1;
		
		for(i=0; s[i] != '\0'; i++)
		{
	            if (s[i]== 'A')
				{
	                sum += 4;
	                num ++;
				}
	                
	            else if (s[i]== 'B')
	            {
				    sum += 3;
	                num++;	
				}
	                
	            else if (s[i]== 'C')
	            {
					sum += 2;
	                num++;
				} 
	            else if (s[i]== 'D')
	            {
				    sum += 1;
	                num++;
				}
	            else if (s[i]== 'F')
	            {
                    sum += 0;
					num++;
				}
	            else if (s[i]== ' ') //记得排除掉  ' '
	            ;
	                
	            else
	            {
					cout << "Unknown letter grade in input" << '\n';
	                flag = 0;
	                break; //要  break;  因为会有诡异输入“E E E E E” .哭了哭了
				}
        }
        if(flag==1)
            printf("%.2lf\n", sum/num);//f 和 lf 都行
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值