UVA - 10815 Andy's First Dictionary

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1756


Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland


Two blondes were going to Disneyland when they came to a fork in the road. The sign read: "Disneyland Left."


So they went home.


Sample Output
a

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when


题目大意:统计一篇文章中的单词,并按其字典序输出,输出时均为小写字母。

思路:set处理。streamstring读取每个单词,tolower(c)将大写字母转为小写。

代码如下:

#include<iostream>
#include<set>
#include<cstring>
#include<cctype>
#include<sstream>
using namespace std;

int main()
{
	string s,s2,s3;
	int i;
	set<string> dic;
	while (getline(cin,s))
	{
		for (i=0;i<=s.length();i++)
		  if (s[i]<='Z' && s[i]>='A' || s[i]<='z' && s[i]>='a')
		    s[i]=tolower(s[i]);
		  else s[i]=' ';
		stringstream ss(s);
		while (ss>>s2) dic.insert(s2);
	}
	set<string>::iterator it;
	for (it=dic.begin();it!=dic.end();it++)
	  cout<<*it<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值