Hdu 1005 解题报告

Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5

话说看到这道题,我看到他的表达式和N的范围,第一个想到的是矩阵乘法加快速幂。。时间复杂度O(logn)。。然后我写了一天(其实没有一天,就半小时),然后调试了好久(因为最近事多,时间太零碎了),然后做出来,高高兴兴的提交了。。然后悲剧的TLE。。话说hdu的题目就是这么恶心人。格式控制,特殊情况判断。。以下是我第一次提交的代码。。

#include <stdio.h>

#define MOD 7

void calc(int a[][2], int b[][2])

{

    int c[2][2], i, j;

    for(i = 0; i < 2; i++)

        for(j = 0; j < 2; j++)

            c[i][j] = a[i][0]*b[0][j] + a[i][1]*b[1][j];

    for(i = 0; i < 2; i++)

        for(j = 0; j < 2; j++)

            a[i][j] = c[i][j] % MOD;

}

int main()

{

    int a, b, n;

    while(scanf("%d%d%d", &a, &b, &n), (a||b||n)) {

        a %= MOD; b %= MOD;

        int mat[2][2] = {0, b, 1, a};

        int ans[2][2] = {1, 1, 0, 0};

        for(--n; n; n >>= 1){

            if(n&1) calc(ans, mat);

            calc(mat, mat);

        }

        printf("%d\n",ans[0][0]);

    }

    return 0;

}

为什么会悲剧呢? 因为数据中很多n==1 和 n==2 的情况,然后用矩阵乘法得不偿失。。所以加上特判就过了(这是我后来看别人的博客发现的)

悲剧了之后,我就今讨论区看了看,发现几乎没人用矩阵(是不是太低端了= =#),几乎都是用的数论找周期然后。。。神奇的变成了%49。。。

看了看大神的证明。。然后懂了。hdu1005 Number Sequence 这里证明。下面贴我的代码。。。

#include <stdio.h>

#define MOD 7

int main()

{    int a, b, n, i, F, f[60];

    while(scanf("%d%d%d", &a, &b, &n), (a||b||n))

    {

        f[1] = f[2] = 1;

        for(i = 3; i < 50; i++)

            f[i] = (a*f[i-1] + b*f[i-2]) % MOD;

        printf("%d\n",f[n%49]);

    }

    return 0;

}

在此之前,我先提交的我的矩阵乘法版本的AC代码(就加了个特判 笑cry):

#include <stdio.h>

#define MOD 7

void calc(int a[][2], int b[][2])

{

    int c[2][2], i, j;

    for(i = 0; i < 2; i++)

        for(j = 0; j < 2; j++)

            c[i][j] = a[i][0]*b[0][j] + a[i][1]*b[1][j];

    for(i = 0; i < 2; i++)

        for(j = 0; j < 2; j++)

            a[i][j] = c[i][j] % MOD;

}

int main()

{

    int a, b, n;

    while(scanf("%d%d%d", &a, &b, &n), (a||b||n))

    {

        if(n == 1 || n == 2){

            printf("%d\n", 1);

            continue;

        }

        a %= MOD; b %= MOD;

        int mat[2][2] = {0, b, 1, a};

        int ans[2][2] = {1, 1, 0, 0};

        for(--n; n; n >>= 1){

            if(n&1) calc(ans, mat);

            calc(mat, mat);

        }

        printf("%d\n",ans[0][0]);

    }

    return 0;

}

然后是我发现要用特判的那个博客:hdu 1005_尉传庆_新浪博客

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值