Oulipo--KMP算法

 

Oulipo
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 25 (22 users)Total Accepted: 22 (22 users)Special Judge: No
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

    一道很经典的KMP题目,笔者用了四个小时去看了各种KMP算法的文章,本来打算最后总结一下,自己写一篇通俗易懂的KMP算法解释的,但是看了另一位大佬的KMP算法的详解之后,觉得自己写得再怎么精彩也不可能超过TA写的那篇了,这里给出链接,希望各位看完之后,能对KMP有更深的了解。

    传送门http://www.cnblogs.com/SYCstudio/p/7194315.html

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int F[10005];


int main()
{
    int t,sum;
    cin>>t;
    while(t--)
    {
        sum=0;
        string a,b;
        cin>>b>>a;
        memset(F,0,sizeof(F));
        F[0]=-1;
        int len1=a.size();
        int len2=b.size();
        int i,j;
        for(i=1;i<len2;i++)
        {
            j=F[i-1];
            while((b[j+1]!=b[i]) && (j>=0))
                j=F[j];
            if(b[j+1]==b[i])
                F[i]=j+1;
            else
                F[i]=-1;
        }
        i=0;
        while(i<len1)
        {
            if(a[i]==b[j])
            {
                i++;
                j++;
                if(j==len2)
                {
                    sum++;
                    j=F[j-1]+1;
                }
            }
            else
            {
                if(j==0)
                    i++;
                else
                    j=F[j-1]+1;
            }
        }
        cout<<sum<<endl;
    }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值