hdu - 1045 Fire Net 二分图匹配

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
在这里插入图片描述
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input
4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0

Sample Output
5
1
5
2
4

给你n行n列的一张图,让你在.的地方放城堡,每个城堡同行同列如果有别的城堡则会被它摧毁,但是如果城堡中间有X就可以阻止这种现象的发生,问你最多可以放几个城堡。
可以这样来理解题意:行和X将原图分成了不同的区域,标为集合1;列和X也将原图分成了不同的区域,标为集合2。在.处放上城堡,相当于把这个点在集合1和在集合2所在区域都占据了,由此我们想到了二分图匹配。
行的情况:
行的情况
列的情况:
在这里插入图片描述

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int n;
char maps[10][10];
int vis[10], used[10], G[20][20],x[20][20],y[20][20];
int row, col, ans, f, tmp;
int dfs(int u){
	for (int j = 1;j <= col; ++j){
		if(vis[j] || !G[u][j]) continue;
		vis[j] = 1;
		if(!used[j] || dfs(used[j])){
			used[j] = u;
			return 1;
		}
	}
	return 0;
}
solve(){
	row = col = ans = 0;
	mem(G, 0);
	mem(maps, 'X');
	for (int i = 1;i <= n; ++i){
		scanf("%s", maps[i] + 1);
	}
	for (int i = 1;i <=n ; ++i){
		for (int j = 1; j <= n; ++j){
			if (maps[i][j]=='.'){
				row++;
				while(maps[i][j] == '.'){
					x[i][j] = row; //标记集合1的区域编号
					j++;
				}
			}
		}
	}
	for (int j = 1;j <=n; ++j){
		for (int i = 1; i <= n; ++i){
			if(maps[i][j] == '.'){
				col++;
				while(maps[i][j] == '.'){
					y[i][j] = col;//标记集合2的区域编号
					i++;
				}
			}
			
		}
	}
	for(int i = 1;i <=n ;++i){
		for(int j =1;j<=n;++j){
			if (maps[i][j] == '.') G[x[i][j]][y[i][j]] = 1;//求关系矩阵
		}
	}
	mem(used, 0);
	for(int i = 1;i <= row; ++i){
		mem(vis, 0);
		if(dfs(i))
			ans++;
	}
	printf("%d\n", ans);
}
int main(){
	while(~scanf("%d", &n), n)
		solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值