pat:1021

http://pat.zju.edu.cn/contests/pat-b-practise/1021


1021. 个位数统计 (15)

给定一个k位整数N = dk-1*10k-1 + ... + d1*101 + d0 (0<=di<=9, i=0,...,k-1, dk-1>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定N = 100311,则有2个0,3个1,和1个3。

输入格式:

每个输入包含1个测试用例,即一个不超过1000位的正整数N。

输出格式:

对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M。要求按D的升序输出。

输入样例:
100311
输出样例:
0:2
1:3
3:1


// PAT, 简单题集


#include <stdio.h>
#include <cctype>
#include <cmath>
#include <cstring>

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>


#define SIZE 1010

using namespace std;

int main(){
#ifdef ONLINE_JUDGE
#else	
	freopen("E:\\in.txt", "r" , stdin);
#endif

	char buf[SIZE];
	while(scanf("%s", buf) != EOF){
		int hash[20]={0};
		int i=0;
		while(buf[i] != '\0'){
			hash[buf[i]-'0']++;
			i++;
		}//while

		for(i=0; i<=9; i++)
		{
			if(hash[i] != 0)
				printf("%d:%d\n", i, hash[i]);
		}
	}//while


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值