1004. Counting Leaves (30)

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output

0 1

/*
这题好像是树的存储和遍历的问题;
输入:
第一行:N(总的树的节点数),M(非叶子节点的个数)
接下来M行是 ID(非叶子节点的ID),K(他有K个子女),接下来K个子女的ID
输出:
输出各个层的叶子节点数,以空格为间隔符,最后无空格

个人方法:
感觉自己做的有点乱七八糟;
直接用一个二维矩阵存储了每行非叶节点的信息,将其子女的ID依次存放在node[ID][0],node[ID][1]等等
然后用深度优先搜索,将节点(在这时是结构体)依次压入优先队列中(按节点的level排序)
然后清空queue来计算每层的叶节点数,若其node[ID][0]是0那么这个节点时叶节点。 
*/
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
struct node_level
{
	friend bool operator< (node_level n1, node_level n2)
    {
        return n1.level > n2.level;
    }
	int level;
	int ID;
}a,b;
int node[100][100];
int k[100];
int ID[100];
priority_queue<node_level>q;
void dfs(int level,int ID)
{
	a.level=level;
	a.ID=ID;
	q.push(a);
	for(int i=0;;i++)
	{
		if(node[ID][i]==0)return;
		dfs(level+1,node[ID][i]);
	}
}
int main()
{
	int index=0;
	memset(node,0,sizeof(node));
	int N,M;
	cin>>N>>M;
	for(int i=0;i<M;i++)
	{
		cin>>ID[i]>>k[i];
		for(int j=0;j<k[i];j++)
		{
			cin>>node[ID[i]][j];
		}
	}
	dfs(0,1);
	
	int count=0;
	int level=0;
	while(!q.empty())
	{
		b=q.top();
		q.pop();
		if(b.level!=level)
		{
			cout<<count<<" ";
			level=b.level;
			count=0;
			if(node[b.ID][0]==0)count++;
		}
		else
		{
			if(node[b.ID][0]==0)
				count++;
		}
	}
	cout<<count<<endl;
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值