1013. Battle Over Cities (25)

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

题意:

1.输入N、M、K,接下来M行,每行输入高速路所连接的两个城市号,接下来一行K个城市号,

2.K城市,依次输出当只有该城市被敌占时,要保持剩余城市连通,则需要重建几条路

思路:

将剩下的城市,计算有几个连通子集,所需新建的路,应为子集数-1


#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int highway[1000][1000];// 高速地图,highway[i][j]==1,则城市i、j连通,否则不连通 
int main()
{
	int N,M,K;
 	int lost[1000];//失去的城市 
 	int visit[1000];//记录剩余城市属于哪个联通子集 
 	memset(highway,0,sizeof(highway));
 	cin>>N>>M>>K;
 	int city1,city2;
 	for(int i=0;i<M;i++)
    {
 		cin>>city1>>city2;
 		highway[city1][city2]=1;
  		highway[city2][city1]=1;
    }
 	for(int i=0;i<K;i++)
    {
 		cin>>lost[i];
    }
 	for(int i=0;i<K;i++)
    {
 	  	memset(visit,-1,sizeof(visit));//标记未访问城市 
   	 	int visited=1;//记录已访问过的城市数 
   	 	int value=0;//当前联通子集号 
      	visit[lost[i]]=0;//标记失去城市 
      	while(visited<N)
	 	{
    		for(int j=1;j<=N;j++)
   	 		{
   	 			if(visit[j]==0)continue;//失去的城市就不再访问 
        		if((visited)==N)break;//所有城市已访问则退出 
        		visited++;
        		for(int k=1;k<=N;k++) 
    			{
    				if(visit[k]==0||(visit[j]==visit[k]&&visit[j]!=-1))continue;//敌占城市不扫描,已归入同一连通子集的不重复扫描 
      				if(highway[j][k]==1&&visit[k]!=0)
        			{
        				if(visit[k]<0&&visit[j]<0)//两个城市都未归入连通子集 
						{
							value++;
							visit[j]=value;
							visit[k]=value;
						}
          				else if(visit[k]<visit[j]) 
          				{
          					/*
				  			*k城市已经归入一个子集,而j城市当前已归入的子集号比k大,
				  			*j城市的子集号要重新给定,并重新将与j有关的道路一次
				  			*/ 
          					if(visit[k]!=-1)
				  			{
				  				visit[j]=visit[k];
				  				k=0;
				  				value--;
				  			}
				          	else visit[k]=visit[j];
          				}
      					else if(visit[j]<visit[k])
      					{
						  	if(visit[j]==-1)visit[j]=visit[k];
						  	else visit[k]=visit[j];//j城市相关道路的重新扫描,k城市子集号需重新给定 
      					}
        			}
    			}
    			if(visit[j]==-1)//j城市是孤立的 
    			{
			    	value++;
			    	visit[j]=value;
			    }
      		}
  		}
  		cout<<value-1<<endl;//保持非敌占城市相连通,所需修复的道路,应为子集数-1; 
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值