POJ---1456.Supermarket(贪心+优先队列)

题目描述

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

http://poj.org/problem?id=1456

题目大意

超市里有n个产品要卖,每个产品都有一个截至时间dx(从开始卖时算起),只有在这个截至时间之前才能卖出并且获得率润dy。
有多个产品,所有可以有不同的卖出顺序,每卖一个产品要占用1个单位的时间,问最多能卖出多少利润。

注意:有可能出现这样的情况:第4天同时有两件profit为100,而第一天最大的就10,那么,第4天的其中一个可以放到第一天来销售,这就意味着,要从后面开始找,不能从前面开始找!

解题:把产品按最后期限从大到小排,然后从最大的那个期限时间往前一天一天推,如果当前天的期限产品没有完全卖出,就放到前一天期限,和前一天最后期限的产品一走卖,利润大的就先卖(贪心)。没有卖出的又放到前一天去卖,这样从大期限往小期限推,因为小期限的产品不可能在大期限时间去卖,而大期限的产品可以在小的期限去卖。

思路1:用一个优先队列(比较规则是先看截止日期,再看利润),每次卖头一个,pop掉后,判断是否还有那天截止卖(但没卖出去)的物品,取出来将它的截止日期减一(意思就是放到前一天去买了,减一目的是使得重新放进去比较的时候正确),再放回队列。(超时,每次重新放进去平均比较logn次,且存在多次拿进拿出操作,像总共就第10天有100个产品利润为100,那每次要全部拿出来减一再放进去)

思路2:用一个数组存数据,按照日期排序,再用一个优先队列只根据利润比较大小,用于存放当天截止卖的物品及“后几天”没有卖掉提前到这天来卖的物品,每天卖的时候从这个队列拿。

要注意输入为0的情况。

AC代码:

#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;

struct Prod
{
    int profit;
    int day;
    friend bool operator<(Prod p1, Prod p2){
        return p1.profit<p2.profit;
    }
};
bool cmp(Prod p1, Prod p2){
    return p1.day > p2.day;
}
int main()
{
    vector<Prod> vec;
    priority_queue<Prod> que;
    int n;
    while (scanf("%d", &n) != EOF){
        for (int i = 0; i < n; ++i){
            Prod prod;
            scanf("%d%d", &prod.profit, &prod.day);
            vec.push_back(prod);
        }
        sort(&vec[0], &vec[0] + n, cmp);
        int i = 0;
        if (n != 0){
            int day = vec[0].day, profit = 0;
            while (!vec.empty() && day != 0){
                while (i<n && vec[i].day == day){
                    que.push(vec[i]);
                    ++i;
                }
                if (!que.empty()){//que存当天截止卖的物品及“后几天”没有卖掉提前到这天来卖的物品
                    profit += que.top().profit;
                    que.pop();
                }
                --day;
            }
            printf("%d\n", profit);
            vec.clear();
            while (!que.empty())
                que.pop();
        }else
            printf("0\n");
    }
    return 0;
}

附测试数据:https://download.csdn.net/download/stark_jc/10372673

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ - 3616是一个题目,题目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问题的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值