LightOJ - 1341(算术基本定理)

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input
2
10 2
12 2
Sample Output
Case 1: 1
Case 2: 2
用到算术基本定理:
算术基本定理可表述为:任何一个大于1的自然数 N,如果N不为质数,那么N可以唯一分解成有限个质数的乘积N=P1a1P2a2P3a3…Pnan,这里P1<P2<P3…<Pn均为质数,其中指数ai是正整数。这样的分解称为 N 的标准分解式。最早证明是由欧几里得给出的,由陈述证明。此定理可推广至更一般的交换代数和代数数论。
存在性
待证命题:大于1的自然数必可写成质数的乘积。
用反证法:假设存在大于1的自然数不能写成质数的乘积,把最小的那个称为n。
非零自然数可以根据其可除性(是否能表示成两个不是自身的自然数的乘积)分成3类:质数、合数和1。首先,按照定义,n大于1。其次,n不是质数,因为质数p可以写成质数乘积:p=p,这与假设不相符合。因此n只能是合数,但每个合数都可以分解成两个小于自身而大于1的自然数的积。设其中a和b都是介于1和n之间的自然数,因此,按照n的定义,a和b都可以写成质数的乘积。从而n也可以写成质数的乘积。由此产生矛盾。因此大于1的自然数必可写成质数的乘积。
唯一性
假设 N=p1p2p3*……pr=Q1Q2……Qs
设 p1<=p2<=p3<=……<=pr,Q1<=Q2<=Q3……<=Qs.这里p和Q均为质数. 显然p1!=Q1 ,不然两边同时约掉,我们就得到更小的两种分解方法数。不妨设p1<Q1,那么我们用p1替换掉等式右边的Q1,得到一个比N更小的数T=p1Q2
Q3……Qs。令N1=N-T,那么由于N有两种表达方式那么N1也有两种表达
**(1)N1=(p1p2p3……pr)-(p1Q2Q3……Qs)=p1(p2
p3*……p-Q2Q3……Qs)
(2)N1=(Q1
Q2……Qs)-(p1Q2Q3……Qs)=(Q1-p1)(Q2Q3*……Qs)*
由于T比N小所以 N1=(N-T),是个正整数,由(1)可以看到p1是N1的一个质因子,因为 N1<N,因此它的质因数分解应该是唯一的,可知p1也应该出现在表达式(2)中,既然p1比所有的Q都要小,因此他不可能是(2)中的某个Q,于是只可能被包含在因子(Q1-p1)中,这也意味着(Q1-p1)/p1是整数,即Q1/p1-1,是整数,即 Q1/p1是整数。因此 p1必须是Q1的一个因子,这与Q1是质数矛盾,所以假设错误。
分解素因数:N=(p1a1)(p2a2)……(pnan).(分解方式唯一)
因此我们的因子个数为 ans(n)=(1+a1)(1+a2)……*(1+an)
(因为假如a1=3,那么一定有p0 p1,p2,p3是N的约数 那么 总个数就是进行乘法 得到因子的总个数ans)
题意:
求a的所有数对中大于等于b的因数对。
思路:因为题目给出 不是正方形,所以两个相同的因子不算 那么ans/2 就是因数对数,然后枚举小于b的a的约数,用num/2减去,

///唯一分解定理
void divide(int n)///质因数分解
{
    int m=0;
    for(int i=2;i<=n;i++)
    {
        if(n%i==0)///i是质数
        {
        p[++m]=i;
        c[m]=0;
        while(n%i==0)
        {
            n/=i;
            c[m]++;
        }
            
        }
    }
    if(n>1)///最后一个质数,也是最大的
        p[++m]=n,c[m]=1;
    for(int i=1;i<=m;i++)
        printf("%d^%d ",p[i],c[i]);
    
}
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
typedef long long ll;
const ll N=1e6+10;
using namespace std;
ll p[N],prime[N],k,num;
void sss()
{
    k=0;
    for(ll i=2; i<=N; i++)
    {
        if(p[i]==0)
        {
            prime[k++]=i;///素数
            for(ll j=i*2; j<=N; j+=i)
                p[j]=1;///合数
                 }
        }
    }///素数筛
    ll f(ll a)///a的素因子个数
    {
        ///n的约数个数为ans(n)=(1+a1)*(1+a2)*...*(1+an).
        num=1;
        for(ll i=0; i<k&&prime[i]<a; i++)
        {
            int x=0;
            while(a%prime[i]==0)
            {
                x++;
                a/=prime[i];
            }
            num*=x+1;
        }
        if(a>1)num*=1+1;
        return num;
    }
    int main()
    {
        sss();
        int t,o=1;
        scanf("%d",&t);
        while(t--)
        {
            ll a,b;
            scanf("%lld %lld",&a,&b);
            {
                if(a<b*b)
                    printf("Case %d: 0\n",o++);
                else
                {
                    ll ans=f(a)/2;
                    for(ll i=1; i<b; i++)
                        if(a%i==0)
                            ans--;
                    printf("Case %d: %lld\n",o++,ans);
                }
            }
        }
        return 0;
    }



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Starry_Sky_Dream

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值