[PAT甲级] 1017 Queueing at Bank (25)

题目:

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2


题目简介:计算一天中所有人在银行排队时长的平均值,8:00:00之前到达的顾客需要等待至8点银行开门,17:00:00之后到达的顾客由于银行关门,需要从计算的样本中去除(17点及之前到达可顺利办理业务)。

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <queue>
using namespace std;

struct customer{
    int arrive;//顾客到达时间,以秒计
    int usetime;//办理业务时间,以秒计
}C[10000];

int gettime(int h, int m , int s){
    return h*3600 + m*60 + s;
}

bool cmp(customer c1, customer c2){
    return c1.arrive < c2.arrive;
}

int total(int N, int K){
    int i, k, totaltime = 0, window[100] = {0};
    //window记录了每一个窗口当前业务结束的时间
    queue<customer> q;

    //先处理8点之前到达的顾客
    for(i = k = 0; C[i].arrive < gettime(8, 0, 0); i++){
        q.push(C[i]);
        totaltime += gettime(8, 0, 0) - C[i].arrive;
    }
    while(!q.empty()){
        customer tmp = q.front();
        q.pop();
        if(k < K){
        window[k] += gettime(8, 0, 0) + tmp.usetime;
        k++;
        }
        //如果k==K,即所有窗口都满了,则需要等待,选一个值最小的window计算等待时间totaltime
        else if(k == K){
            sort(window, window+k);
            totaltime += (window[0] - gettime(8, 0, 0));
            window[0] += tmp.usetime;
        }
    }
    //当8点前的顾客都已经处理完后,处理剩下的顾客
    for(; i < N; i++){
        if(k < K){
            window[k] = C[i].arrive + C[i].usetime;
            k++;
        }
        //这里除了判断k==K,还要注意arrive>=window也是不需要等待的
        else if(k == K){
            sort(window, window+k);
            if(C[i].arrive < window[0]){
                totaltime += (window[0] - C[i].arrive);
                window[0] += C[i].usetime;
            }
            else
                window[0] = C[i].arrive + C[i].usetime;
        }
    }

    return totaltime;
}

int main(){
    int N, K, i, h, m, s, usetime, totaltime = 0;
    scanf("%d%d", &N, &K);
    for(i = 0; i < N; i++){
        scanf("%d:%d:%d %d", &h, &m, &s, &usetime);
        if(gettime(h, m, s) >= gettime(17, 0, 1)){
            i--;
            N--;
            continue;
        }
        C[i].arrive = gettime(h, m, s);
        C[i].usetime = usetime*60;//imput业务时间是以分钟计的
    }
    sort(C, C+i, cmp);//顾客按arrive顺序排序
    totaltime += total(i, K);
    printf("%.1f", totaltime/60.0/i);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值