POJ - 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 30278 Accepted: 15713
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input

ababcababababcabab
aaaaa
Sample Output

2 4 9 18
1 2 3 4 5

题意:数一下所有前缀字符串在整个字符串中出现的总次数。如“abab”为6次,其中’a’出现2次,'ab’出现两次,'aba’出现1次,‘abab’出现1次
思路:KMP套个板子,只需要把pat串匹配txt串的部分修改一下就ok,但是得优化一下,不然铁t,这个题仔细看其实不难发现,前缀字符串随着长度变长,在整个字符串中出现的次数只会越来越少,所以当某个前缀字符串在整个字符串中出现的次数为1时,后面的就不要判断了。

#include <iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 2e5 + 100;
int ne[maxn];
void GetNextval(string p)
{   /*模式串的长度*/
	int pLen = p.size();
	ne[0] = -1;
	int k = -1;
	int j = 0;
	while (j < pLen){
		if (k == -1 || p[j] == p[k]){
			++j;
			++k;
            ne[j] = k;
		}
		else{
			k = ne[k];
		}
	}
}

int KmpSearch(string s, string p)
{
	int i = 0;
	int j = 0;
	int cnt = 0;/*模式串在文本串中出现的次数*/
	int sLen = s.size();
	int pLen = p.size();
	while (i < sLen){
		if (j == -1 || s[i] == p[j]){
			i++;
			j++;
			if(j == pLen)/*模式串与文本串完全匹配,匹配的个数加1*/
                cnt++;
		}
		else{
			j = ne[j];
		}
	}
	return cnt;
}

string s, p;

int main()
{
    int t;
    scanf("%d", &t);
    while(t--){
        int n;
        scanf("%d", &n);
        getchar();
        cin >> p;
        GetNextval(p);
        s = p;
        int ans = 0;
        int i;
        for(i = 1; i <= s.size() ; i++){
            p.resize(i);
            p = s.substr(0, i);
            int re = KmpSearch(s, p);
            ans += re % 10007;
            if(re == 1)break;/*如果当前字串在整个子串中只出现一次,那后面的字串不可能出现俩次*/
        }
        ans += (s.size() - i);/*加上后面的字串的个数,每个字串都出现了一次*/
        printf("%d\n", ans % 10007);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值