小根堆应用

                                                7-12 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T


堆的基本操作:


void up(int u)
{
    int t = u;
    if (u/2 && heap[u/2] > heap[u]) t = u/2;
    if (t != u){
        swap(heap[t],heap[u]);
        up(t);
    }
}
 
void down(int u)
{
    int t = u;
    if (u * 2 <= size && h[u * 2] < h[u]) t = u * 2;
    if (u * 2 + 1 <= size && h[u * 2 + 1] < h[u]) t = u * 2 + 1;
    if (u != t)
    {
        heap_swap(u, t);
        down(t);
    }
}

AC代码:注意题目要求的是:将一系列给定数字顺序插入一个初始为空的小顶堆H[]

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 10100;

int a[N];
int n, m;

void down(int x)
{
    int t = x;  //min_number
    if(x * 2 <= n && a[x * 2] < a[t]) t = x * 2;
    if(x * 2 + 1 <= n && a[x * 2 + 1] < a[t])   t = x * 2 + 1;
    if(t != x)
    {
        swap(a[t], a[x]);
        down(t);
    }
}

void up(int x)
{
    int t = x;
    if(x / 2 && a[x / 2] > a[t])    t = x / 2;
    if(t != x)
    {
        swap(a[t], a[x]);
        up(t);
    }
}

int get(int x)
{
    for(int i = 1; i <= n; i ++ )
        if(a[i] == x)   return i;
        
    return -1;
}

int main()
{
    cin >> n >> m;
    for(int i = 1; i <= n; i ++ )   //一个坑点,题目要求的是按给定数组的顺序构建堆
    {
        cin >> a[i];
        up(i);
    }
    
    // cout << "heap: ";
    // for(int i = 1; i <= n; i ++ )   cout << a[i] << " ";
    // cout << endl;
    
    while(m -- )
    {
        int a, b;
        string s;
        cin >> a >> s;
        
        a = get(a);
        if(s == "and")  //(1)a and b are siblings
        {
            string s1, s2;
            cin >> b >> s1 >> s2;
            b = get(b);
            // cout << "(1): ";
            if(a / 2 == b / 2)  puts("T");
            else    puts("F");
        }
        else // s = "is"
        {
            string s1, s2, s3;
            cin >> s1;
            if(s1 == "a")   //(2)a is a child of b
            {
                cin >> s2 >> s3 >> b;
                b = get(b);
                // cout << "(2): ";
                if(a / 2 == b)  puts("T");
                else    puts("F");
            }
            else  // s = "the"
            {
                cin >> s2;
                if(s2 == "root")//(3)a is the root
                {
                    // cout << "(3): ";
                    if(a == 1)  puts("T");
                    else    puts("F");
                }
                else //(4)a is the parent of b
                {
                    cin >> s3 >> b;
                    b = get(b);
                    // cout << "(4): "; 
                    if(b / 2 == a)  puts("T");
                    else    puts("F");
                }
            }
            
        }
        
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值