HDU 3342 拓扑排序

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9146    Accepted Submission(s): 4239


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
  
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
  
  
YES NO
 

Author
QiuQiu@NJFU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2647  3333  3339  3341  3336 

题解:其实就是给你0到n-1个点,判断是否成环。感觉应该会有孤立点,并且可能有重边。

ac code:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <list>
#include <deque>
#include <queue>
#include <iterator>
#include <stack>
#include <map>
#include <set>
#include <algorithm>
#include <cctype>
using namespace std;

#define si1(a) scanf("%d",&a)
#define si2(a,b) scanf("%d%d",&a,&b)
#define sd1(a) scanf("%lf",&a)
#define sd2(a,b) scanf("%lf%lf",&a,&b)
#define ss1(s)  scanf("%s",s)
#define pi1(a)    printf("%d\n",a)
#define pi2(a,b)  printf("%d %d\n",a,b)
#define mset(a,b)   memset(a,b,sizeof(a))
#define forb(i,a,b)   for(int i=a;i<b;i++)
#define ford(i,a,b)   for(int i=a;i<=b;i++)

typedef long long LL;
const int N=1e5+5;
const int M=6666666;
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
const double eps=1e-7;
vector <int > V[120];
int dge[120];
bool vis[120];
bool vis1[120];

struct cmp
{
    bool operator()(int x,int y)
    {
        return x>y;
    }
};

priority_queue<int ,vector<int > ,cmp > q;

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        for(int i=0;i<=n;i++)
            V[i].clear();
        while(!q.empty()) q.pop();
        mset(vis,0);
        mset(vis1,0);
        mset(dge,0);
        int u,v,sum=0;
        for(int i=0;i<m;i++)
        {
            si2(u,v);
            dge[v]++;
            V[u].push_back(v);
            if(!vis1[u])sum++,vis1[u]=1;
            if(!vis1[v])sum++,vis1[v]=1;//标记点是否出现过
        }
        for(int i=0;i<n;i++)
        {
            if(!dge[i]&&vis1[i])//出现过的点进入队列中
                q.push(i),vis[i]=1;
        }
        int flag=0,num=0;
        if(q.empty()) flag=1;
        while(!q.empty())
        {
            u=q.top();q.pop();
            for(int i=0;i<V[u].size();i++)
            {
                v=V[u][i];
                if(!--dge[v])
                {
                    if(vis[v])//感觉这里没什么用……但还是加上了
                    {flag=1;break;}
                    q.push(v);
                    vis[v]=1;
                }
            }
            if(flag)
                break;
            num++;//记录出现过的点是否全部在队列中出现过
        }
        //printf("%d %d\n",num,sum);
        if(num!=sum) flag=1;
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值