贪心POJ3069

/**
*@ author StormMaybin
*@ date 2016-09-28
*/

生命不息,奋斗不止!

-----
题目描述
Saruman's Army
Time Limit: 1000MS      Memory Limit: 65536K
Total Submissions: 8018     Accepted: 4100

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题目大意:大致可以抽象成一个线段上有几个点,然后这几个点有一个共同的作用范围(意思是出了这个范围就会失效),然后给这几个点添加标记,作用范围之内,添加一个标记就行,问最少可以添加多少个标记。

分析:每次我们找到作用范围最右边的那个点,然后给它添加标记,依次这样,我们贪心的找到最右边的点!

演示代码
    package com.stormma.poj;

    import java.io.BufferedInputStream;
    import java.util.Arrays;
    import java.util.Scanner;

    public class Main3069
    {

        /**
         * @param args
         */
        private Scanner scan = null;
        public Main3069 ()
        {
            scan = new Scanner(new BufferedInputStream(System.in));
            while (scan.hasNext())
            {
                int R = scan.nextInt();
                int N = scan.nextInt();
                if (R == -1 && N == -1)
                {
                    System.exit(0);
                }
                int [] maze = new int [N];
                for (int i = 0; i < N; i++)
                    maze[i] = scan.nextInt();
                Arrays.sort(maze);
                int i = 0;
                int ans = 0;
                while (i < N)
                {
                    //s是没有被覆盖的最左的位置
                    int s = maze[i++];
                    //一直向右前进直到距s的距离大于R的点
                    while (i < N && maze[i] <= s + R)
                    {
                        i++;
                    }
                    int p = maze[i-1];
                    while (i < N && maze[i] <= p + R)
                    {
                        i++;
                    }
                    ans++;
                }
                System.out.println(ans);
            }
        }
        public static void main(String[] args)
        {
            // TODO Auto-generated method stub
            new Main3069();
        }

    }
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值