1009 Product of Polynomials (25分)

测试地址:

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题意:求两个多项式的积。

思路:

建立数组 a[ ],长度比指数的最大值 1000 稍大即可,将第一个多项式用标记数组的方法存入到数组中;

建立数组 b[ ],每个多项式的指数最大为1000,相乘之后最大也就是2000,故数组 b[ ] 的长度最小为 2000;

数组 b 中用来存放两个多项式相乘后的结果,在输入第二组数据时,利用 b 数组来进行运算和存储,指数,即 b 数组的下标为两个多项式的指数部分的乘积,即 两个指数相加,所对应的值为两个多项式的系数相乘。

最后,统计两多项式的和共有几项,输出,之后再按指数的从大到小输出指数和相应的系数。

c++代码:

#include<iostream>
#include<cstring>
using namespace std;
double a[1010]={0.0}, b[2020]={0};
int main(){
	int k1, k2, n, t=0;
	double x;
	cin >> k1;
	for(int i = 0; i < k1; i++){
		cin >> n >> x;
		a[n] = x;
	}
	cin >> k2;
	for(int i = 0; i < k2; i++){
		cin >> n >> x;
		for(int j = 0; j < 1001; j++){
			b[j+n] += a[j]*x;
		}
	}
	for(int i = 0; i < 2001; i++){
		if(b[i])	t++;
	}
	cout << t;
	for(int i = 2000; i >= 0; i--){
		if(b[i]){
			printf(" %d %.1lf", i, b[i]);
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值