1062 Talent and Virtue (25分)

测试地址:

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10​5​​), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

【题意】

刚开始没理解题意,翻译了好久,呜呜~~~     得加强英语

第 1 行给出3个正整数

分别为:

N为考生总数;

L为录取最低分数线,即德分和才分均不低于 L 的考生才有资格被考虑录取;

H为优先录取线——德分和才分均不不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;

才分不不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;

德才分均低于H,但是德分不不低于才分的考⽣生属于“才德兼亡”但尚有“德 胜才”者,按总分排序,但排在第二类考生之后;

其他达到低线 L 的考生也按总分排序,但排在第三类考生之后。

输出第 1 行首先给出达到低分数线的考生人数M,随后 M 行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列列;若德分也并列列,则按准考证号的升序输出。

【思路1】

用结构体存储学生的 id,德才分和总分以及他们是第几类考生,弄个优先级,方便后面判断,之后在 cmp 函数中写排序即可。

【AC代码1】

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1e5+7;
int n, l ,h;
typedef struct{
	string ID;
	int Virtue, Talent, sum, rank;
}stu;
stu a[maxn], b[maxn];
int cmp(stu a, stu b){
	if(a.rank == b.rank){
		if(a.sum == b.sum){
			if(a.Virtue == b.Virtue){
				return a.ID < b.ID;
			}
			return a.Virtue > b.Virtue;
		}
		return a.sum > b.sum;
	}
	return a.rank < b.rank;
}
int main(){
	cin >> n >> l >> h;
	int t = 0;
	for(int i = 0; i < n; i++){
		cin >> a[i].ID >> a[i].Virtue >> a[i].Talent;
		a[i].sum = a[i].Virtue+a[i].Talent;
		if(a[i].Virtue>=l && a[i].Talent>=l){
			if(a[i].Virtue>=h && a[i].Talent>=h){
				a[i].rank = 1;
			}
			else if(a[i].Virtue>=h && a[i].Talent<h){
				a[i].rank = 2;
			}
			else if(a[i].Virtue >= a[i].Talent){
				a[i].rank = 3;
			}
			else{
				a[i].rank = 4;
			}
			b[t++] = a[i];
		}
	}
	cout << t << endl;
	sort(b, b+t, cmp);
	for(int i = 0; i < t; i++){
		cout << b[i].ID << " " << b[i].Virtue << " " << b[i].Talent << endl;
	}
	return 0;
}

【思路2】

用结构体存储。写好cmp函数

结构体数组 vector v[4] 中 v[0] 保存第一类考生,v[1] 保存第二类考生……以此类推

cmp函数中,排序先按照总分排序,然后按照德分排序, 后按照才分排序……

后输出符合条件的结果

(柳婼的思路,感谢!🙇‍)

【AC代码2】

#include <iostream> 
#include <algorithm> 
#include <vector> 
using namespace std; 
struct node {    
	int num, de, cai; 
}; 
int cmp(struct node a, struct node b) {    
	if ((a.de + a.cai) != (b.de + b.cai))        
		return (a.de + a.cai) > (b.de + b.cai);    
	else if (a.de != b.de)        
		return a.de > b.de;    
	else        
		return a.num < b.num; 
} 
int main() {    
	int n, low, high;    
	scanf("%d %d %d", &n, &low, &high);    
	vector<node> v[4];    
	node temp;    
	int total = n;
	for (int i = 0; i < n; i++) {        
		scanf("%d %d %d", &temp.num, &temp.de, &temp.cai);        
		if (temp.de < low || temp.cai < low)            
			total--;        
		else if (temp.de >= high && temp.cai >= high) 
		    v[0].push_back(temp);        
		else if (temp.de >= high && temp.cai < high)  
		    v[1].push_back(temp);        
		else if (temp.de < high && temp.cai < high && temp.de >= temp.cai)   
		    v[2].push_back(temp);        
		else            
			v[3].push_back(temp);    
	}    
	printf("%d\n", total);    
	for (int i = 0; i < 4; i++) {        
		sort(v[i].begin(), v[i].end(), cmp);        
		for (int j = 0; j < v[i].size(); j++)     
		    printf("%d %d %d\n", v[i][j].num, v[i][j].de, v[i][j].cai);    
	}    
	return 0; 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值