PTA-03-树2 List Leaves

该博客介绍了如何处理一个给定的树结构,并列出所有从上到下、从左到右的叶子节点。通过输入的节点数量和它们的子节点关系构建树,使用层序遍历的方法找出并按顺序打印叶子节点。
摘要由CSDN通过智能技术生成

题目描述

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5


解答

思路:
结构体数组建立树
层序遍历树 遇到左右儿子都为空的结点即为叶节点

#include<iostream>
#include<queue>
using namespace std;

struct Tree{
    int Lchild;
    int Rchild;
    int data;
}T[10];
int check[10]={0};
queue<int> q;
int Build(int n)
{
    char Lchild;
    char Rchild;
    if(n==0) return -1;//空树
    for(int i=0;i<n;i++){
        cin>>Lchild>>Rchild;
        T[i].data=i;
        if(Lchild=='-'){
            T[i].Lchild=-1;
        }else{
            T[i].Lchild=Lchild-'0';
            check[T[i].Lchild]=1;//表明该节点有父亲结点
        }
        if(Rchild=='-'){
            T[i].Rchild=-1;
        }else{
            T[i].Rchild=Rchild-'0';
            check[T[i].Rchild]=1;
        }
    }
        int Root;
        for(Root=0;Root<n;Root++){
            if(!check[Root]) break;//找到Root结点
        }
        return Root;
}
//层序遍历 输出叶子节点
void level_traversal(int Root)
{
    int temp;
    int flag=0;
    if(Root==-1) return;
    q.push(Root);
    while(!q.empty()){
        temp=q.front();
        q.pop();
        if(T[temp].Lchild==-1&&T[temp].Rchild==-1){
            if(flag==0){
                flag=1; 
                cout<<T[temp].data;
            }
            else cout<<" "<<T[temp].data;
        }
        if(T[temp].Lchild!=-1) q.push(T[temp].Lchild);
        if(T[temp].Rchild!=-1) q.push(T[temp].Rchild);
    }
}

int main()
{
    int n;
    int Root;
    cin>>n;
    Root=Build(n);
    level_traversal(Root);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值