PTA-08-图8 How Long Does It Take

题目描述

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible


/*
拓扑排序
有向图
*/

#include<cstdio>
#include<iostream>
using namespace std;
#define Inf 0x3f3f3f3f
int N,M;
int map[10001][10001];
int ECT;
#include<queue>

int get_max(int arr[])
{
    int max=0;
    for(int i=0;i<N;i++){
        if(max<arr[i]){
            max=arr[i];
        }
    }
    return max;
}
int top_sort()
{
    int V,cnt=0,Indegree[10001]={0},earliest[10001]={0};
    queue<int> q;
    //计算各结点的入度
    for(int i=0;i<N;i++){
        for(int j=0;j<N;j++){
            if(map[i][j]!=Inf) Indegree[j]++;
        }
    }
    //入度为0的入队
    for(int i=0;i<N;i++){
        if(Indegree[i]==0){
            q.push(i);
        }
    }
    while(!q.empty()){
        V=q.front();
        q.pop();
        cnt++;
        for(int j=0;j<N;j++){
            if(map[V][j]!=Inf){//map<V,j>存在有向边
                if(earliest[V]+map[V][j]>earliest[j]){
                    earliest[j]=earliest[V]+map[V][j];
                }
                if(--Indegree[j]==0){
                    q.push(j);
                }
            }
        }
    }
    ECT=get_max(earliest);//最早完成时间是所有元素最大的
    if(cnt!=N) return 0;//若没有取出所有元素 说明存在回路
    else return 1;
}

int main()
{
    cin>>N>>M;
    for(int i=0;i<N;i++){
        for(int j=0;j<N;j++){
            map[i][j]=Inf;
        }
    }
    for(int i=0;i<M;i++){
        int v1,v2,w;
        cin>>v1>>v2>>w;
        map[v1][v2]=w;
    }
    if(!top_sort()) cout<<"Impossible"<<endl;
    else cout<<ECT<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值