poj 2479 2593 最大字段和

poj2479
Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37842 Accepted: 11827

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

需要注意这个算法的是:

对于求最大字段和的时候:若是a[ i ]<0 也是灭有关系的,因为要是前面的和也是小于0 的,那么下一个也是小于0 的

要是前面字段和不是小于0 ,那么字段和就会有下降,所以后面的一个循环可以取最大的值,直接就掩盖了小于0 的缺陷

#include<stdio.h>
#include<algorithm>
using namespace std;

int a[50001];
int left[50001];
int right[50001];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
//-----------------初始化输入------------------//
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);

//---------------左字段最大--------------------//
        left[0]=a[0];
        for(int i=1;i<n;i++)
            if(left[i-1]<0)
                left[i]=a[i];
            else
                left[i]=a[i]+left[i-1];
        for(int i=1;i<n;i++)
            left[i]=max(left[i],left[i-1]);

  //---------------右字段最大--------------------//
        right[n-1]=a[n-1];
        for(int j=n-2;j>=0;j--)
            if(right[j+1]<0)
                right[j]=a[j];
            else
                right[j]=a[j]+right[j+1];
        for(int j=n-2;j>=0;j--)
            right[j]=max(right[j],right[j+1]);

//---------------得出所需要的答案--------------------//
        int ans=-0xfffffff;
        for(int i=1;i<n;i++)
            ans=max(ans,right[i]+left[i-1]);
        printf("%d\n",ans);
    }
    return 0;
}


poj2593

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 

You should output S. 

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40
#include<stdio.h>  
#include<algorithm>  
using namespace std;  
  
const int MAX=100005;  
  
int a[MAX];  
int b[MAX];  
  
int main()  
{  
    int n;  
    while(scanf("%d",&n),n)  
    {  
        for(int i=0;i<n;i++)  
            scanf("%d",&a[i]);  
  
        int temp=0;  
        int ans=-0xfffffff;  
        for(int i=0;i<n;i++){  
            temp+=a[i];  
            if(temp>ans)  
                ans=temp;  
            if(temp<0)  
                temp=0;  
            b[i]=ans;  
        }  
  
        ans=-0xfffffff;  
        temp=0;  
        int bug=-0xfffffff;  
        for(int i=n-1;i>0;i--){  
            temp+=a[i];  
            if(temp>ans)  
                ans=temp;  
            if(temp<0)  
                temp=0;  
            bug=max(bug,ans+b[i-1]);  
        }  
        printf("%d\n",bug);  
  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值