hdu 6092 递推

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 108    Accepted Submission(s): 41


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .

Now, Yuta has got 2n numbers between [0,m] . For each i[0,m] , he counts the number of i s he got as Bi .

Yuta shows Rikka the array Bi and he wants Rikka to restore A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number t(1t70) , the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n50,1m104) .

The second line contains m+1 numbers B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with n numbers A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
  
  
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$
 

Source



题意:

a数组中有n个数,任意组合得到2的n次方个数字,给出这些数字的出现的频率b数组,求原数组a

题解:

从小到大枚举,我们很容易知道第一个数,那么就可以通过第一个数任意组合推知接下来的第二个

比赛的时候是这样的思路,但是循环写的不一样没有break,导致超时,调换循环结构然后剔除不必要的就而已过了



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAXN 10005
long long b[MAXN],t[MAXN];
int ans[MAXN];
long long c[30][30];

void init()
{
    memset(c,0,sizeof(c));
    for(int i=0; i<=21; i++)
    {
        c[i][0]=1;
        for(int j=1; j<=i; j++)
            c[i][j]=c[i-1][j-1]+c[i-1][j];
    }
}

int main()
{
    init();
    int n,m,T;
    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<=m; i++)
            scanf("%lld",&b[i]);


        int i,j,k;
        for(i=1;i<=m;i++){
            if(b[i]==0)
                continue;

            for(j=i+1;j<=m;j++){
                for(k=1;k<=b[i];k++){
                    if(j-i*k<i)   break;
                    if(j-i*k!=i)  b[j]-=c[b[i]][k]*b[j-i*k];
                    else          b[j]-=c[b[i]][k+1];
                }
            }
        }

        int flag=1;
        for(i=1;i<=m;i++)
        {
            while(b[i]--)
            {
                if(flag) flag=0;
                else  printf(" ");
                printf("%d", i);
            }
        }
        puts("");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值