hdu 4336 容斥原理 2012 Multi-University Training Contest 4

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4592    Accepted Submission(s): 2319
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500
 

Source



题意:

给出n个卡片出现的概率,卡片都是单独出现,不能一次出现多张


题解:

对于第一个样例,出现第一张的期望为 1.0/.01   出现第二张的期望为 1/0.4 

此时我们就想用容斥原理,就要减去在一包中可能出现这两张的概率(不是同时出现,只是可能出现这两张的概率)是 0.1 + 0.4

然后减去这个期望值  1/ (0.1 + 0.4)

很容易发现这就是一个容斥了

然后稍微搞一搞就过了


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAXN 100
double a[MAXN],ans;
int n;
void dfs(int now,double num,int sym)
{
    ans+=1.0/num*sym;
    for(int i=now+1;i<=n;i++)
        dfs(i,num+a[i],-1*sym);
}

int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%lf",&a[i]);

        ans=0;
        for(int i=1;i<=n;i++)
            dfs(i,a[i],1);
        printf("%0.4lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值