HD Problem A ,POJ 3660 Cow Contest.(Floyd,传递闭包).

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 28   Accepted Submission(s) : 10

Problem Description

 

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

 

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

 

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

 

 

Input

 

<p>* Line 1: Two space-separated integers: <i>N</i> and <i>M</i><br>* Lines 2..<i>M</i>+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, <i>A</i>, is the winner) of a single round of competition: <i>A</i> and <i>B</i></p>

 

 

Output

 

<p>* Line 1: A single integer representing the number of cows whose ranks can be determined<br> </p>

 

 

Sample Input

 

5 54 34 23 21 22 5

 

 

Sample Output

 

2

 

 

题意:给定几对牛之间的关系,求出有几个牛的关系是唯一确定的:floyed算法的变形应用 :

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int f[101][101];
int main()
{
    int  n,m,win,lose;
    scanf("%d%d",&n,&m);
    memset(f,0,sizeof(f));
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d",&win,&lose);
        f[win][lose]=1;
    }
    for(int k=1;k<=n;k++)//floyed算法变形
        for(int i=1;i<=n;i++)
           for(int j=1;j<=n;j++)
             f[i][j]=f[i][j]||(f[i][k]&&f[k][j]);//确定i,j两点之间是否相连
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        int t=0;
        for(int j=1;j<=n;j++)
        {
            if(f[i][j]||f[j][i]) t++;//

        }
        if(t==n-1) sum++;
    }
    printf("%d\n",sum);
   return 0;
}

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值