POJ 3660 Cow Contest.(Floyd,传递闭包).

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 43   Accepted Submission(s) : 15
Problem Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

 

Input
<p>* Line 1: Two space-separated integers: <i>N</i> and <i>M</i><br>* Lines 2..<i>M</i>+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, <i>A</i>, is the winner) of a single round of competition: <i>A</i> and <i>B</i></p>
 

Output
<p>* Line 1: A single integer representing the number of cows whose ranks can be determined<br> </p>
 

Sample Input
 
  
5 5 4 3 4 2 3 2 1 2 2 5
 

Sample Output
 
  
2
 
不会做:看别人的题解

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
int n,m;  
int d[105][105];  //传递背包,一头和其他牛的关系确定了,名次也就 确定了
int Floyd()  
{  
    for(int k=1;k<=n;k++)  
        for(int i=1;i<=n;i++)  
            for(int j=1;j<=n;j++)  
                d[i][j]=d[i][j]||(d[i][k]&&d[k][j]);//传递闭包, 记录i和j的关系(直接或间接)是否确定。  
}  
int main()  
{  
    while(scanf("%d%d",&n,&m)==2)  
    {  
        int a,b;  
        memset(d,0,sizeof(d));  
        for(int i=1;i<=m;i++)  
        {  
            scanf("%d%d",&a,&b);  
            d[a][b]=1;  
        }  
        Floyd();  
        int ans=0;  
        for(int i=1;i<=n;i++)  
        {  
            int sum=0;  
            for(int j=1;j<=n;j++)  
                if(d[i][j]||d[j][i])    sum++;  
            if(sum==n-1)
                ans++;  
        }  
        cout<<ans<<endl;  
  
    }  
    return 0;  
}  




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值