POJ 3617 Best Cow Line (字典序最小_贪心)

Problem V

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 7
Problem Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

 

Input
<p>* Line 1: A single integer: <i>N</i><br>* Lines 2..<i>N</i>+1: Line <i>i</i>+1 contains a single initial ('A'..'Z') of the cow in the <i>i</i>th position in the original line</p>
 

Output
<p>The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.</p>
 

Sample Input
 
  
6ACDBCB
 

Sample Output
 
  
ABCBCD
 
题意:开头 与结尾比较小的输出,相同时在比较下一个——输出较小的,一行输出超过80个字符换行,scanf输出单个字符时注意空格g类型字符串
#include<iostream>
#include<cstdio>
using namespace std;
char s[2222];
bool check(int l,int r)
{
    while(l<=r) {
        if(s[l]==s[r]) {
            l++;
            r--;
        }
        else if(s[l]>s[r]) return false;
        else return true;
    }
    return true;
}

int main()
{
    int i,j,l,r,n,sigh;
    cin>>n;
    sigh=0;
    for(i=1;i<=n;i++) cin>>s[i];
    l=1;r=n;
    while(l<=r) {
        if(s[l]<s[r]) cout<<s[l++];
        else if(s[l]>s[r]) cout<<s[r--];
        else {
            if(check(l,r)) cout<<s[l++];
            else cout<<s[r--];
        }
        sigh++;
        if(sigh==80) {
            cout<<endl;
            sigh=0;
        }
    }
    cout<<endl;
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值