hdu1397Goldbach's Conjecture

Sum of Consecutive Prime Numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28491 Accepted: 15275

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

思路:用下标存储素数,标记下标是素数的值为0,通过一个循环判断i及n-i若都是素数则输出

代码:

#include<cstdio>
using namespace std;
const int maxn=1000008;
long long isprime[maxn];
void prime()///素数打表,素数都为0
{
    long long i,j;
    for(i=2; i<=maxn; i++)
    {
        if(!(isprime[i]))
        {
            isprime[i]=0;///保存素数
        }
        for(j=i*2; j<=maxn; j+=i)
        {
            isprime[j]=1;///素数的倍数都不是素数
        }
    }
}
int main()
{
    long long  n,ans;
    prime();
    while(scanf("%lld",&n)!=EOF)
    {
        if(n==0) break;
        ans=0;
        for(int i=2;i<=n/2;i++)
        {
            if(isprime[i]==0&&isprime[n-i]==0)
            {
                ans++;
            }
        }
        printf("%lld\n",ans);
    }
    return  0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值