hdu5606 Tree (并查集)

There is a tree(the tree is a connected graph which contains nn points and n−1n−1edges),the points are labeled from 1 to nn,which edge has a weight from 0 to 1,for every point i∈[1,n]i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain ii itself. 

Input

the first line contains a number T,means T test cases. 

for each test case,the first line is a nubmer nn,means the number of the points,next n-1 lines,each line contains three numbers u,v,wu,v,w,which shows an edge and its weight. 

T≤50,n≤105,u,v∈[1,n],w∈[0,1]T≤50,n≤105,u,v∈[1,n],w∈[0,1]

Output

for each test case,you need to print the answer to each point. 

in consideration of the large output,imagine ansiansi is the answer to point ii,you only need to output,ans1 xor ans2 xor ans3.. ansnans1 xor ans2 xor ans3.. ansn. 

Sample Input

1
3
1 2 0
2 3 1

Sample Output

1

in the sample.

$ans_1=2$

$ans_2=2$

$ans_3=1$

$2~xor~2~xor~1=1$,so you need to output 1.

题意:

       给定n-1条边,两点间边的权值是0或者1,默认每个点到自身的距离为0,计算每个点到最短相邻点的的个数,将最后的结果异或输出。

分析:

       每个点到自身结点的距离为0 ,所以权值为1的点可以省去,将权值为0的点连成链,同一条链上的点到最近的点的数量必定是相同的,通过查找父亲节点的次数,得出每条链上的点到最近点的数量。

 

代码:

#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int fa[100008];
int ans[100008];
int findset(int x)
{
    return fa[x]==x? x: fa[x]=findset(fa[x]);
}
void bind(int x,int y)
{
    int fx=findset(x);
    int fy=findset(y);
    if(fx!=fy)
    {
        fa[fx]=fy;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
            memset(ans,0,sizeof(ans));
            int x,y,n,w,ans2=0;
            scanf("%d",&n);
            for(int i=1;i<=n;i++)///每个点的自身也是他的父亲节点,权值为0
            {
                fa[i]=i;
            }
            for(int i=1;i<n;i++)
            {
                scanf("%d%d%d",&x,&y,&w);
                if(w==0)///每个到最近的点的距离肯定是0,则将权值为0的边连接即可
                {
                   bind(x,y);
                }
            }
            for(int i=1;i<=n;i++)
            {
              fa[i]=findset(i);///一条链上的到相邻最近的数量是相同的,代表点为整条链的父亲节点
              ans[fa[i]]++;///查找链根节点的次数,就是这条链每个点到临近节点的数量
            }
            for(int i=1;i<=n;i++)
            {
                ans2=ans[fa[i]]^ans2;///由于每个点的结果都在父亲节点存储着,然后异或即可
            }
            printf("%d\n",ans2);
    }
    return 0;
}

   

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值