POJ - 1724 ROADS

28 篇文章 0 订阅

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

这是一道最短路的题目,意在找出能够负担的起并且最短的一条路。

可以考虑使用Dijkstra,但是要有限制条件,以前的Dijkstra是更加短的进入队列,现在改完之后就变成了if (需要花的钱+花的钱 <= 有的钱)就加入队列。

#include <cstdio>
#include <queue>
using namespace std;

struct node
{
    int u;
    int distance;
    int cost;
    bool operator < (const node &a) const
    {
        return distance > a.distance;
    }
};
struct node_edge
{
    int from, to;
    int price;
    int len;
}edge[10000 + 5];
int vis[100 + 5] = {0};
int money, num_city, num_road;

int dijkstra()
{
    priority_queue<node> q;
    node a;
    a.u = 1;
    a.distance = 0;
    a.cost = 0;
    q.push(a);

    while (!q.empty())
    {
        node now = q.top();
        q.pop();
        if (now.u == num_city)
            return now.distance;
        for (int i = vis[now.u]; i != 0; i = edge[i].from)
        {
            if (now.cost + edge[i].price <= money)
            {
                a.u = edge[i].to;
                a.distance = now.distance + edge[i].len;
                a.cost = now.cost + edge[i].price;
                q.push(a);
            }
        }
    }
    return -1;
}

int main()
{
    int pos = 1;

    scanf("%d%d%d", &money, &num_city, &num_road);
    for (int i = 0; i < num_road; ++i)
    {
        int u;
        scanf("%d%d%d%d", &u, &edge[pos].to, &edge[pos].len, &edge[pos].price);
        edge[pos].from = vis[u];
        vis[u] = pos++;
    }
    printf("%d\n", dijkstra());
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值