HDUOJ - 1710 Binary Tree Traversals

54 篇文章 0 订阅
Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
  
  
7 4 2 8 9 5 6 3 1
 


一个简单的二叉树的不同顺序遍历的输出,用后序遍历找到与前序遍历相同的一个,前面的就是左子树,后面的右子树。

#include <cstdio>

int pre[1005], mid[1005];

void print(int start1, int start2, int siz, bool flag)
{
    if (siz == 1)//如果存在左子树或右子树就直接输出
    {
        printf("%d ", pre[start1]);
        return;
    }
    else if (siz <= 0)//如果不存在左子树或右子树就返回上一层
        return;

    int i;
    for (i = 0; i < siz && pre[start1] != mid[start2+i]; ++i);//找到根节点
    print(start1+1, start2, i, false);//左子树
    print(start1+i+1, start2+i+1, siz-i-1, false);//右子树

    if (flag)//最上面的根节点
        printf("%d\n", pre[start1]);
    else//一般的根节点
        printf("%d ", pre[start1]);
}

int main()
{
    int n;
    while (scanf("%d", &n) != EOF)
    {
        for (int i = 0; i < n; ++i)
            scanf("%d", &pre[i]);
        for (int i = 0; i < n; ++i)
            scanf("%d", &mid[i]);
        print(0, 0, n, true);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值