POJ 2697 - A Board Game

28 篇文章 0 订阅

Description

Dao was a simple two-player board game designed by Jeff Pickering and Ben van Buskirk at 1999. A variation of it, called S-Dao, is a one-player game. In S-Dao, the game board is a 4 * 4 square with 16 cells. There are 4 black stones and 4 white stones placed on the game board randomly in the beginning. The player is given a final position and asked to play the game using the following rules such that the final position is reached using the minimum number of moves:
  • 1. You first move a white stone, and then a black stone. You then alternatively move a white stone and a black stone.
    2. A stone can be moved horizontally, vertically or diagonally. A stone must be moved in a direction until the boarder or another stone is encountered. There is no capture or jump.
    3. During each move, you need to move a stone of the right color. You cannot pass.

An example of a sequence of legal moves is shown in the following figure. This move sequence takes 4 moves. This is not a sequence of legal moves

using the least number of moves assume the leftmost board is the initial position and the rightmost board is the final position. A sequence of moves using only 3 moves is shown below.

Given an initial position and a final position, your task is to report the minimum number of moves from the initial position to the final position.


Input

The first line contains the number of test cases w, w <= 6. Then the w test cases are listed one by one. Each test case consists of 8 lines, 4 characters per line. The first 4 lines are the initial board position. The remaining 4 lines are the final board position. The i-th line of a board is the board at the i-th row. A character 'b' means a black stone, a character 'w' means a white stone, and a '*' means an empty cell.

Output

For each test case, output the minimum number of moves in one line. If it is impossible to move from the initial position to the final position, then output -1.

Sample Input

2
w**b
*wb*
*bw*
b**w
w**b
*wb*
*bw*
bw**
w**b
*b**
**b*
bwww
w**b
*bb*
****
bwww


Sample Output

1
3


题意:在一个4*4的棋盘中,有白色和黑色棋子【w代表白色,b代表黑色】。给出一个开始的情况,再给出一个结束的情况,每次先移动白棋,然后黑棋,每次移动能够向8个方向中的其中一个移动到棋盘边界或者碰到其他棋子。求出达到结束情况最少需要多少步。

直接使用深搜即可,注意将每次移动到底。

#include <cstdio>
#include <cstring>

int dp[8][2] = {{1,0}, {-1,0}, {0,1}, {0,-1}, {1,1}, {1,-1}, {-1,1}, {-1,-1}};
char turn[2] = {'w', 'b'};
char start[20], result[20];

inline bool confirm(int x, int y)
{
    return (x >= 0 && y >= 0 && x <= 3 && y <= 3);
}

bool DFS(char maps[], int step, int n, int sym)
{
    if (step == n)
    {
        if (strcmp(maps, result) == 0)
            return true;
        return false;
    }

    for (int i = 0; i < 4; ++i)
    {
        for (int j = 0; j < 4; ++j)
        {
            if (maps[i*4 + j] != turn[sym])
                continue;
            for (int k = 0; k < 8; ++k)
            {
                int x = i;
                int y = j;
                while (confirm(x + dp[k][0], y + dp[k][1]) == true &&
                       maps[(x + dp[k][0])*4 + y + dp[k][1]] == '*')
                {
                    x += dp[k][0];
                    y += dp[k][1];
                }
                maps[x*4+y] = turn[sym];
                maps[i*4+j] = '*';

                if (DFS(maps, step+1, n, 1-sym) == true)
                    return true;
                maps[x*4+y] = '*';
                maps[i*4+j] = turn[sym];
            }
        }
    }
    return false;
}

int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        memset(start, 0, sizeof(start));
        memset(result, 0, sizeof(result));
        for (int i = 0; i < 4; ++i)
            scanf("%s", start + 4*i);
        for (int i = 0; i < 4; ++i)
            scanf("%s", result + 4*i);
        int ans = 0;
        while (true)
        {
            if (DFS(start, 0, ans, 0) == true)
            {
                printf("%d\n", ans);
                break;
            }
            ans++;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值