POJ 3041 - Asteroids

28 篇文章 0 订阅

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).


题意:有一个小行星带分布成一个矩形在XOY坐标轴上,每条激光从 X轴或 Y轴上的某一点射出,横向或纵向,可以将在这同一条直线上的小行星全部击毁,问最少几次攻击。给出 n 和 k 分别代表 n*n 的矩阵,k 个小行星,下面有 k 行,每行是 x y 坐标。

简单的二分图匹配,每个点集一定有顶点,将每个顶点进行一次射击即可。

#include <cstdio>
#include <cstring>

bool maps[500 + 5][500 + 5], vis[500 + 5];
int match[500 + 5];
int n;

bool DFS(int u)
{
    for (int v = 1; v <= n; ++v)
    {
        if (maps[u][v] && !vis[v])///v没有访问过
        {
            vis[v] = true;
            if (match[v] == -1 || DFS(match[v]))///v还能构成别的点集
            {
                match[v] = u;
                return true;
            }
        }
    }
    return false;
}

int maxmatch()
{
    int ret = 0;
    memset(match, -1, sizeof(match));
    for (int u = 1; u <= n; ++u)
    {
        memset(vis, false, sizeof(vis));
        if (DFS(u))
            ret++;
    }
    return ret;
}

int main()
{
    int k;
    while (scanf("%d%d", &n, &k) != EOF)
    {
        memset(maps, false, sizeof(maps));
        for (int i = 0; i < k; ++i)
        {
            int a, b;
            scanf("%d%d", &a, &b);
            maps[a][b] = true;
        }
        int ans = maxmatch();
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值